IOS 14 WiFi

Anyone experiencing issues with IOS 14 and wifi connectivity?
Post not yet marked as solved Up vote post of TonySFL Down vote post of TonySFL
49k views
  • Since yesterday morning, I have issues with WIFI on my iPhone 11 with iOS 14.6

    I can connect to the Wifi but I don't get the wifi icon at the top of the display and most applications claim "No internet Access". Despite this, some things load correctly, probably via 4G. So text works fine for example in messenger, but not pictures. I have rebooted the phone, I have done a couple of HW resets and I have done a reset of the network settings. No change. I have tried two different wifi networks, so it is not router related (different types of routers). Other equipment including my Macbook and my iPad as well as the rest of the family has no issues, only my iPhone 11. As there is no shell available in iOS, it's hard to find out what is really going on. Any suggestions, or do I need to backup to my computer and make a factory reset and if that doesn't help, take it in for repair ??

    Thanks

  • To add a bit more - Apple CarPlay have also stopped working. One last resort before going to the repair shop was to erase the phone and then install an older backup from the computer. Turned out to be a bit hard, as it tries to connect to apple to remove it from my account, and as the network isn't working, the erase procedure fails with "Verification failed".

Add a Comment

Answers

I also had issues, using wifi on iOS 14 actually broke the network. All other devices connected to the same router (either via wifi or ethernet) started experiencing the same issues.
Managed to make wifi work correctly by disabling the automatic DNS on my router and assigning it manually on all devices. This workaround seemed to be working on iPadOS, I still have to test it on macOS Big Sur as it had the same issue.
I'm having similar issues, but with 13.5.1 and 13.6 Beta 2. My issue is a bit different - my devices technically work, but they all believe they are on cellular. If I try and do an IOS update, it hangs on Update Requested, and something about my network not being suitable. If I try to download large app (even on an iPad Wifi-only device) it asks if I'm sure I want to download on cellular. If I say to continue it downloads on WiFi.

If I turn off every wifi device on my network, hardcode my IP and DNS, then turn off DHCP on my router, it solves the issue. This is not an answer though, as I have about 28 Wifi devices, and some are difficult to hardcode. I cannot disable DNS on my router, only by disabling DHCP can that be done.

The only way I can do an update (like from 13.5.1 to 13.6 beta) on Wifi is to connect to another wifi router, where I am the only device.

This was definitely introduced with 13.5.1 as that was when my issues started. My Photostream stopped working at that time also - presumably because it thinks all my iDevices are on cellular.

I've reported the bug. I can't pin down how to fix this - I'm pretty technical, but if Apple is broadcasting something on the Wifi that's interfering, then I'm at a loss. One theory is something is triggering devices to think they are on a Personal Hotspot, as they behave the same when actually connected to one.
I have tracked down my issue to being an incompatibility between iOS 13.5.1 and above and a fairly new DLink router. There was no issue until I updated to 13.5.1. Not sure if it's a DLink issue or an IOS issue, but it's definitely the DLink combined with iOS 13.5.1 and up.
My issues with the WiFi is that it keeps asking for a new IP address almost every time I'm away for a long period (5+hours). The same is happening with my AppleWatch.
I am having similar issues. If I am away from the WIFI for more than a few hours, my iPhone reconnects and requests a new IP address. This happens whether or not the "Use Private Address" is turned on or off.
I ran into some issues connecting to my wife 5 instead of 2.4. The five isn’t even showing as an option sometimes. I wonder if there’s a bug with the five antenna chip
Downloaded iOS 14 yesterday. Both of my wireless connections refused to stay connected for more than a couple minutes. New Netgear router/ modem. No issues with any other wireless connections in the house. Finally resorted to downgrading back to iOS 13.7. Everything works again like it did previously. Any ideas?
Aftee i downloaded ios 14 - hs so many issues:
  1. App store cannot be accessed anymore using wifi - even my macbook was affected. Using mobile data seems to work. But had to edit some settings in my macbook certificate so I could access app store via wifi.

  2. Some apps become offline when on wifi. I could not use apps like tinder when on wifi. Mobile still is working

I did IOS 14 update, looks like apple don't test software before releasing, I did network rest, factory reset none of it seem to work.

Service desk suggest how to fix this issue.

thanks

yep! should have checked for the ios 14 review. now my phone wont connect with the wifi, and its impossible to move nearer to the modem as it is in the main house. ugh!
Yes, Downloaded to 2 iPhones yesterday. Now both are dropping Wi-Fi signal from router. Tried all the usual switching on and off, but no luck. Another iPhone that has not downloaded IOS14 is working fine.
Yes have upgraded to 14 IOS and wifi is now flaky. The wifi is ubiquity pro access points and all other wifi devices are ok.

let’s a patch come very soon.
I am facing the same issue since i updated my device to IOS14, and IOS13.7 was working perfectly fine but not after the 14th update,,, I went to apple store for service appointment, all they offered is to hand my iPhone 11 pro max for 10 days before i am eligible for a replacement i was like no i am not spending 10 days without a phone.
Same here... iOS 14 made the wifi very instable. Factory reset, restart, nothing works... I rely wi-fi heavily for working from home, and heavily paying the price for immediate update to iOS 14 right after the release.