iOS 14 no signal, no cellular data

Hi!
I've installed iOS beta 4 on my iPhone 11 Pro and since then, I lost the signal and I don't have data. I have another iPhone X with iOS 14, and I don't have issue with it. It only occurs on iPhone 11.

I tried many things like:
  • Reset network setting

  • Turn off/on airplane mode

  • Turn off/on cellular data

  • Hard reboot

  • Soft reboot

  • Reset content and data

  • Turn off/on roaming

...
Same issues
It seems that the cell is looking for the signal constantly.

Do you have any idea how to fix it ?
Post marked as unsolved Up vote post of ropims Down vote post of ropims
4.6k views

202 Replies

iPhone XS here.
started to have issues only after updating to iOS 14. Suddenly lose all network connection, just says “searching”, no bars.

Toggling flight mode doesn’t fix it, have to reboot the phone.
Just and update, iOS 14.2 beta 4 includes a modem update and I thought that may solve this issue. I installed the update on iPhone XS 2 days ago and everything was working fine. I was able to make and attend calls, messages and used 4g data as well. Then I charged my phone overnight and for some reason the issue started happening again. Tried restarting the device and everything else but to no avail. One thing is for sure, the problem is related to iOS 14.
my phone was working fine until i updated to the newest update which is 14.1 and my Airtel sim suddenly stopped working and the "no sim card inserted" and "searching" pop ups showing up... my primary sim which is Airtel works in other android or iPhones in my house which are on 14.0.1 but not in my phone... please let me know if there is any solution to this issue.
thankyou.
Have the same issue with iPhone 7 and 14.0.1 and 14.1.

Initially could get cell signal working by popping out the sim or going to manual mode... but now cannot get to the cellular screen. Reset network settings doesn't go through. Restart and DFU recovery don't make a difference.
This fix may work but when you use Wifi-calling you NEED automatic mode as the "provider" switches from the main network to a "<operator name> Wi-fi". I live in a low signal area (which seems like a commonality for this issue) and my phone goes to Wifi calling in parts of the house. THIS is the trigger for it never getting back onto the main network (without reboot) when you leave Wifi. It is a bad bug as you have no idea your phone has no service, dangerous in some situations. Hope it is addressed very soon.
I’ve tried out the solution suggested by Bug_reporter and so far my phone network has not been lost when using 4G

Steps:
  1. Settings > Mobile Data > Network Selection

  2. Disable "Automatic"

  3. Select your mobile network manually

  4. Restart the iPhone

After that, try to toggle airplane mode and check if the mobile network connection still works.

 
Same type issue with both an iphone 7 and an iphone 8. After updating ios, cell service is constantly 'searching' and both phones only work now on wifi. Can't adjust cellular settings because there is nothing under 'cellular' when I look in the menu. SIM card ID no longer shows up in settings/general/about (although the carrier does). Also can't reset network settings. Phone freezes for a bit after trying and then resumes operation, but never shuts down (and it doesn't help). Daughter's iphone 7 started having the issue 3 days ago. Son's 8 started yesterday. Chatted and talked for hours and hours with Apple.. did everything they came up with and nothing worked. Double checked the SIM card registrations with the carrier and even put a brand new SIM in the 7. Still nothing.
Did a full restore after backup on the 7 and now it won't activate. Error message ranges from 'activation server is temporarily unavailable' to 'an update is required to activate your phone' (it's running 14.1.. fully updated). Hooking it up to my Mac, says activation information can not be obtained from the device. Have tried DFU multiple times. No change.

Have not done a full restore on the 8 because of what happened with the 7. But the 8 is showing all the same issues (searching, nothing under cellular, network reset won't work, no SIM info in about menu, etc). Would love it if someone has any other ideas.
I have iphone 6S with airtel sim. After upgrading to ios software version 14.1 . I am not getting airtel network. I have other android phones with airtel sim and they are working fine. Please look into this issue as soon as possible. At least provide us any quick solution for now.
I’m able to resolve this by turning my phone off and on again, which is the reason I’m here looking for the proper solution!
Same here: Spain Jazztel (omv) - XS 64

All work fine until I move with car seems like goes to no service and there is no solution, phone needs to be restarted. IOS 14.1 still having the issue. With previous versions never happened.

if you always have the 3G mode, this issue seems be solved but... i cannot suffer the speed difference
This is ridiculous. Doesn’t Apple read our complaints? How about someone from Apple replying to us ? Nope . No care whatsoever. Useless piece of crap sitting on the desk now . We are all paying a phone line but can’t use it as a phone . Amazing !
Apple , i have always loved your products and have been a loyal apple costumer . This is about to change . You are clearly not concerned about all these peoples issues.
You messed our phones with the iOS 14 update , you need to fix it for us .


3rd update, for me the issue only pops up when roaming. Spend a few days in Belgium so on my "local" provider, no issues what so ever using 4G.
Now back in the UK, no connection on O2 or Vodafone, just does not want to connect. EE still same, connection but unable to receive/make calls, force to 3 and mobile data 3G works fine [unless 3 has no coverage in an area]. Still this does not solve the no service issue and should be a termp workaround.

iphone XS
iOS 14.2beta3 [because got a stable connection not sure of upgrading to beta4 unless I see someone that can confirm it fixes the issue]
At the poster below,  Bug_reporter - dude I couldn't even get into the that menu when I got the error.
I will repost this because it seems almost nobody reads the older messages:

Steps:
  • Settings > Mobile Data > Network Selection

  • Disable "Automatic"

  • Select your mobile network manually

  • Restart the iPhone

After that, try to toggle airplane mode and check if the mobile network connection still works.
Having the same exact problem with my son's iPhone 7. He upgraded to 14.01. Got the cellular error. I tried to upgrade to 14.1 - upgrade failed. I tried to restore from backup - phone went into cycle between Apple logo and black. I forced phone into recovery mode and restored to factory settings. This worked but still have the cellular error, therefore can't even activate the phone now.

I found this URL - https://support.apple.com/iphone-7-no-service/other-countries

Going to call Apple today and see what they say.