Can't save gifs anymore ios 14?

Can't save gifs, it just saves frame of it as a photo.
  • Hello!!! Same problem here! please fix this!

  • https://ezgif.com

    i had the same issue and used a “static” gif that was saved with just 1 frame on this site and it recognized it as a gif with the missing frames to, i wonder if it has to do with the photos app itself not displaying gifs properly? ive also noticed that i cant upload transparent bg images to discord without it loosing transparency and if your transparent image is too small (talking 100 x 100) then it also looses transparency but that one doesnt repost with transparency unlike this gif situation (however when i uploaded the small image with lost transparency to a photo editing/art app on my phone it DID upload with a transparent bg so idk what the deal is)

Add a Comment

Replies

  • *****YES!!!! If you use Safari Browser to download/save gifs from Tenor.com they WILL save to your recent photos *as a GIF*** not a picture only (ios 14.3)

If you use Chrome or Google, it says "cannot save image" when you try to save it to your device.
I went the route of downloading an app called gif breaker. I only used it once but it did exactly what i needed. Turned the gif into a video and now i can post to Reddit.
This is obviously Apple blocking third-party apps. They don't want us using anything other than Apple apps. Especially anything created by Microsoft or Google.

I hate Safari's mobile browser interface - it's a piece of sh*t. Chrome's interface is much better, in my opinion.

I'll probably stick with an iphone for the remainder of my contract, but after 13 years with an iphone, I'll probably move back to a droid, as much as I do not want to do that.

Get bent, Apple.
Iphone with ios 14.2 here.
It is neither a browser nor ios issue, at least for me.

Many animated gifs are more and more webp, so not actually gifs. *These* cannot be played in the roll (only shows a frame). Gifs can still play.

Try googling for a basic animated gif, save to roll, then see if it plays.
I can't save gifs while im using google chrome but it works if you save them in safari

Download Maxhton 5 and choose save image to album. Thank me later
I fixed mine by deselecting “Optimize iPhone Storage” and selecting “Download and Keep Originals” in settings. When I got my iPhone 12 with iOS 14 this no longer worked. Just changed that setting and now I can save gifs and they are animated Photos. However, the gifs I downloaded prior to making the change are still broken. Probably have to re-download them.
If you use safari instead of chrome it works just fine, but it is annoying af having to use a different browser to do that instead of just saving it from an app or chrome in general
Use Maxthon 5 browser. It was the ultimate solution for me.
This problem exists on macOS Big Sur as well. It is so frustrating! Shouldn't Apple be giving us more capabilities, and not taking them away??? It's getting harder and harder to be pro Apple products.
Not sure if it’s been posted yet but I found a workaround. When you find a gif online, hold down to select it, COPY it, & PASTE it in a text message to yourself. From there you can select & save it to your phone as a gif.
Having the same problem after getting a new MacBook Pro with Big Sur. However, what I did notice is that it is not happening with all GIF's I have attempted to save. It appears to be happening with GIF's made with a specific format. I can save some GIF's, and others I can't.
This simple task still can’t be fixed?
It’s easy. Download Giphy. Download any gif u want. Then when it’s in your cameraroll and not moving swipe up on the gif and select repeat or the other one and you will see that the gif works and u can send it as well.

Hope it’s clear, sorry if my english isn’t crystal clear i’m from Holland and English it’s not my native language.

Have a nice day, bless you all.
Hi! I had this problem too, so I tried copying the GIF, and then sent it to myself via email, when I got it, I downloaded the GIF, and it was working! But if you want to edit it, you could screen record the GIF, then edit it that way I guess. I hope this helped!