Xcode 12.3 is not Responding a few seconds after Opening it

I updated to Xcode 12.3 on my MacBook Pro 2018 13" yesterday and face a strange Issue now.

Problem: Every Time I open Xcode, it will first work fine. However, after a few Actions / Seconds, the Screen is freezing and the Circle Loading Indicator is displayed. The App is not responding anymore and I have to force close it.

More Information:
  • The Freezing is Xcode specific. I can use all other Programs while Xcode is frozen and the Circle is spinning. It doesn't seem like a Ressource Problem

  • This not only happens with existing Projects, I created a new one and encountered the same Problem

  • I alredy reinstalled Xcode, does not solve the Problem

  • I already deleted the ~/Library/Developer Folder *(like a few other posts recommended)* and Installed the Components on Xcode Start again. Still the same Problem.

Has anyone an Idea on how to solve this Problem?

Thanks for your help.

Solved Answer

I experience the same thing too.
Turns out the problem is wireless debugging.
Go to devices and disable Connect via network solves the problem.

Happy Coding!

16 Replies

I'm seeing the same issue you've described ever since updating to 12.3. In fact even if I don't open a project and open a few of the Xcode preferences screens, I'm seeing the spinner and the Xcode become unresponsive. In Activity Monitor, Xcode shows "Not Responding" and it's usually 1-2 minutes of waiting. This happens with most operations, and makes working in Xcode nearly impossible.

I'm having the same issue with 12.3. Every few minutes, it just hangs with the spiny disc for about a minute. Making it utterly unusable. Trying to figure out how to downgrade to 12.2
I fixed this by downgrade the Xcode version to 12.2
Exactly, delete Xcode, go to: https://developer.apple.com/download/more/
Search for 12.2, download and install it!

Should work.

Cheers!

Bart
Some problem here.

I was using Xcode 12.3 on Catalina without any issue, I've updated to Big Sur and Xcode got the same problem you described. Reinstalled Xcode, all went well for yesterday.
In the evening to solve other issues after the Big Sur update (touch Id not working, couldn't access to iCloud password in Safari and so on...) I had to reset the SMC. The problem was my account was no more recognised as the administrator. Now it is.
This morning Xcode has presented the same problem as yesterday, I've reinstalled it again hoping that being again the administrator the reinstall solves. It hanged a little, a couple of times at the beginning, now it seems to work properly. Will see and let you know.

[Edit:] No it doesn't work. I'm going to downgrade to Xcode 12.2 :-(

I experience the same thing too.
Turns out the problem is wireless debugging.
Go to devices and disable Connect via network solves the problem.

Happy Coding!
Same problem here using Catalina. Disabling Connect via network (as mentioned above) doesn't help.
Xcode 12.3 is unusable. Thank you Apple.
I am facing exactly the same issue Xcode 12.3 is not Responding after a few seconds I open SwiftUI project. I have extremely annoying problem with autocompletion too under SwiftUI project -> there is no autocompletion especially in viewModel files (I have to wait ~30sek to see somethig). In Xcode 12.3 I am not be able to develop my apps. Apple please do something with those issues!
This is happening to me also. I disabled connect via network last night, worked fine. This morning however it's back to crashing... back to 12.2 I go
I have to correct me.  Disabling "Connect via network" works for me, Xcode needed a restart.
This is the worst release ever. You can't do nothing. It just spins and spins. And crashes a lot also.
Reverting back to 12.2.
Disable device via network was also successful for me. Thanks to lokakien.
Like others, I was pulling my hair out with constantly spinning cursors with 12.3 on Big Sur 11.1.
Downgrading to 12.2 immediately solved the problem, and I have been working for three weeks with no problem.

XCode 12.4 was released today, and I installed it and have had no problems so far.
FWIW, I have not yet installed Command Line Tools for Xcode 12.4 -- I'm still running 12.2 of those.
I have been facing the problem with 12.4, lokakien's "disabling Connect via network" solution seems working for me as well.
I am on MacOS 10.15.7 with Xcode 12.4 and I am facing the same problem.
Seems to be related to debugging - unfortunately it also applies to the Simulator in my case.

This is pretty unacceptable for a 'professional tool' I have to say. I need to get work done (which involves debugging in my case!)
Do I need to upgrade to Big Sur? (which probably keeps me busy for another day).
Downgrade to 12.2? (Really?!!)

What is the quickest way out of it - given I need latest SwiftUI libraries on iOS?
(and I guess this is rhetorical question as nobody from Apple seems to care?)