Xcode 12.5 beta 2 no network/internet with Simulator

Is there a setting am I missing or Simulator is just broken on Beta 2 and won't go on the Internet?

Xcode 12.4 is working fine. Other devs see this as well.

Nothing in the release notes.

Any workaround?
I'm having the same problem :(
I also have the identical issue. Are you all using a silicon Mac?
I have the same issue.
Apple silicon MacBook pro (m1)
For AppStore's version unstoppable circle loading...
Tried to use 12.5 beta 2.
Doesn't work the network.

Guys try to use the simulator with iOS 14.0.
It should work. But canvas for swiftUI has the same issue. And I don't know how to resolve it.
Same issue here, Mac Mini M1 :-/
I see the same issue on an Intel 16" MBP, it's not M1 specific.
The release notes list this as a Known Issue under Simulator

You can’t log into iCloud on a simulated device running iOS 14.5, iPadOS 14.5, tvOS 14.5, or watchOS 7.4. (74295005)

Actually, not exactly the same as OP, but related, and also how I stumbled on the issue. Please file a Feedback. One of my recent ones was in the Resolved section.

I can now confirm that loading iOS 14.4 simulator runtime with 12.5 Beta 2 does have network connection.
Same issue here! The problem only happens on Simulator using iOS 14.5, other versions are fine.

mcOS Big Sur 11.1, Macbook Pro 2019 and mcOS Big Sur 11.1, Macbook Pro 2018
Having the same issue. Building on devices is fine.
MacBook Pro 15'' 2019
Xcode 12.5. On an iOS 14.5 simulator application is not able to make any network calls.
Other iOS versions on the Simulators are fine.

Error Domain=NSURLErrorDomain Code=-1200 "An SSL error has occurred and a secure connection to the server cannot be made." UserInfo={NSLocalizedRecoverySuggestion=Would you like to connect to the server anyway?, _kCFStreamErrorDomainKey=3, NSErrorPeerCertificateChainKey=(

    "<cert(0x7f9cb5020200) s: mobile-config.slyce.it i: GTS CA 1D2>",

    "<cert(0x7f9cb5020a00) s: GTS CA 1D2 i: GlobalSign>"
I'm having the same problem.

Using imageUrl pointing to a generic https: .... .jpg file here is an example code which fails in current 14.5 simulator (it actually never returns w/ data or error code but sometimes times out on console) but works in 14.4 simulator. A lot of things should be broken in 14.5 if low level functionality like this fails.

Code Block
URLSession.shared.dataTask(with: imageUrl as URL) { data, response, error in
                DispatchQueue.main.async {
                    if let data = data {
                        if let image = UIImage(data: data as Data) {
- or -
            let downloadQueue = DispatchQueue(label: "fab.image", attributes: .concurrent)
            downloadQueue.async() {
                let data = NSData(contentsOf: imageUrl as URL)
                if data != nil {
                    if let image = UIImage(data: data! as Data) {

Also running into the same issue here on Xcode-beta 2 and iOS 14.5 simulators, seems like all network calls are failing.
the same problem here
My colleagues and I have seen the same problem on x86 MBP's. No network activity works on iOS 14.5 under simulator. Mobile Safari is unable to connect to any website http or https.
Any workarounds?
Following this thread (https://developer.apple.com/forums/thread/674277?answerId=662833022#662833022), it appears that this is a 14.5 simulator bug. Running iOS 14.5 on an actual device should work fine, in case this helps anyone.
I'm experiencing the same error. Also, networking callback blocks never get called.

The following are some errors that I get on the console:

Code Block bash
2021-02-26 10:44:03.254223-0300 someapp[60402:1358928] Connection 6: received failure notification
2021-02-26 10:44:03.254373-0300 someapp[60402:1358928] Connection 6: failed to connect 3:-9816, reason -1
2021-02-26 10:44:03.254469-0300 someapp[60402:1358928] Connection 6: encountered error(3:-9816)

Code Block bash
2021-02-26 10:44:03.285567-0300 Preguntados[60402:1358635] Task <61134D07-7245-4043-85FF-E6003D3E08C5>.<1> finished with error [-1001]
Error Domain=NSURLErrorDomain Code=-1001 "The request timed out."
NSUnderlyingError=0x600001172b20 {
Error Domain=kCFErrorDomainCFNetwork
Code=-1001 "(null)"
_NSURLErrorFailingURLSessionTaskErrorKey=LocalDataTask <61134D07-7245-4043-85FF-E6003D3E08C5>.<1>,
_NSURLErrorRelatedURLSessionTaskErrorKey=("LocalDataTask <61134D07-7245-4043-85FF-E6003D3E08C5>.<1>"),
NSLocalizedDescription=The request timed out.,

it looks like 14.5 beta 3 still has this issue.
On my side, I don't have this issue anymore with Xcode 14.5 Beta 3.
Same issue on Intel Mac mini, not M1.
Xcode Version 12.5 beta 3 (12E5244e) has fixed this issue for me running the iOS 14.5 (18E5164d) simulator.
on my side, this issue doesn't appear on 14.5 beta 3 simulator after my Proxyman tool get updated.
Xcode 12.5 beta 2 no network/internet with Simulator