macOS Monterey: "This app will not work with future versions of macOS"


I'm the developer of a macOS application named Hopper Disassembler.

I have updated my application so that it works properly under macOS Monterey. But I'm getting a warning when I first launch the application: "Hopper Disassembler needs to be updated. This app will not work with future versions of macOS..."

Unfortunately, the "Learn More…" button does nothing, and I don't see any relevant message in the Console application.

The application is a universal binary, containing both Apple Silicon and Intel 64 bit architectures.

How can one find why this warning is triggered?

Thank you!

  • Is it sandboxed ? Ar at least notarised ?

  • Thank you for your response. The application is not sandboxed, because it would break some of the features. But it is notarised, yes. In the console, I can see messages regarding the verification of the notarisation, there is no issue on that side.

Add a Comment


If an app uses Python 2.7, macOS now triggers an alert indicating that the developer must update the app to ensure it will work in future versions of macOS. (80221011)

Your app may be getting that error because it's using a deprecated version of Python.

  • IntelliJ was also getting the same error:
  • CodeWeaver's CrossOver was (or is?) dealing with the same issue.

For the curious, here's how the prompt looks:

  • Hi,

    Thank you for your detailed answer.

    It makes sense, and it was the conclusion I previously had. In the previous versions of Hopper, I was linking against the python dylib provided by the macOS. But I have moved away from this approach, and now, the application is dynamically loading the user provided Python framework at runtime. The other reason was also to support Python 3, as Python 2 is now deprecated. As the warning appears way before the application is launched, I suspect that it has nothing to do with its runtime behaviour. But maybe I'm wrong.

    I have double-checked that I was not linking against the system provided Python framework, but it appears that it is not the case; the command : % find Hopper\ Disassembler\ -type f -and -perm -0111 -exec otool -L {} ";" | grep -i python returns nothing related to Python.

    My other guess is that it may be related to WebKit; there is a way to purchase a license directly from the application, and the (pretty outdated) framework provided by FastSpring still uses the deprecated WebKit class. I'm currently implementing my own version using WKWebKit, but it takes a while as the new class missing some features which I really need.

    Anyway, this is a little bit sad that there is no more information logged into the system regarding the cause of this warning message. Especially considering that this warning only appears at the very first launch of the application... It makes tracking the issue even harder.

  • Yeah, agreed that this warning isn't giving much information right now. Hope you can get it sorted

Add a Comment

@bSr43 Did you file a bug report or contact Apple support directly ?

  • @Claude31 Not yet, but this is what I've planned to do if I'm unable to sort it out with my next attempt (i.e. replacing usages of WebKit)

Add a Comment

@Claude31 Not yet, but this is what I've planned to do if I'm unable to sort it out with my next attempt (i.e. replacing usages of WebKit)

Hi @bSr43, this issue is now more than a warning on macOS 12.3 -- it won't even start because of the Python linking

Translated Report (Full Report Below)

Process:               Hopper Disassembler v4 [39280]
Path:                  /Applications/Hopper Disassembler Disassembler v4
Identifier:            com.cryptic-apps.hopper-web-4
Version:               4.5.29-demo (4.5.29-demo)
Code Type:             X86-64 (Translated)
Parent Process:        launchd [1]
User ID:               503

Date/Time:             2022-03-01 13:25:27.9372 -0800
OS Version:            macOS 12.3 (21E5206e)
Report Version:        12
Anonymous UUID:        9B77F7F9-7508-220F-103F-00FDAB632535

Sleep/Wake UUID:       0563712E-352D-4EBF-801C-E0CC153B224F

Time Awake Since Boot: 980000 seconds
Time Since Wake:       137212 seconds

System Integrity Protection: disabled

Crashed Thread:        0

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    Namespace DYLD, Code 1 Library missing
Library not loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
Referenced from: /Applications/Hopper Disassembler Disassembler v4
Reason: tried: '/System/Library/Frameworks/Python.framework/Versions/2.7/Python' (no such file)
(terminated at launch; ignore backtrace)

Application Specific Information:
Library not loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
Referenced from: /Applications/Hopper Disassembler Disassembler v4
Reason: tried: '/System/Library/Frameworks/Python.framework/Versions/2.7/Python' (no such file)

  • Hi @andini, Even I am facing the same issue with codeweavers applications. It started crashing with same error [Library not loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python]. I am searching for solutions but could not find any. Hope this will be fixed soon by developer updating it.

Add a Comment

I have ran into this issue myself today and what i found out is that Apple removed the python(2.7) framework(previously found in /System/Library/Frameworks/Python.framework), this is why you get the error. What I did and worked for me was to install python 2.7 from the official python website. This will install as a normal application and afterwords you will get the framework in /Library/Frameworks/Python.Framework .

This worked for me, hopefully for you guys as well

Hi Tommie18

how did you get the framework in /Library/Frameworks/Python.Framework? i reinstalled python 2.7 from official python website and i do not have a folder /Library/Frameworks/Python.Framework

  • Have you downloaded and installed the .pkg file from—labelled "macOS 64-bit installer"?

Add a Comment