Run Xcode 13.x on macOS Ventura?

  • i have same problem i am new here but here not working

Add a Comment

Apple Recommended


It's Betas all the way down.

Ventura > Xcode 14 > iOS 16

Note also that even with Xcode 13.4 you would not be able to submit to appStore:

Builds of your app are not accepted by the App Store if any part of the build uses a beta — that includes both an Xcode beta, as well a released Xcode running on a macOS beta.

  • hm... I'm pretty sure I submitted apps with a "minor" beta, i.e. a Monterey beta 12.5. But that may be a different scenario as e.g. there is no workaround needed to start Xcode...

Add a Comment

Having the same problem here. I accidentally installed Ventura on my main volume and now I can't do anything 😭

The error dialog tells me to update to 13.4.1 but I already have 13.4.1.

  • Same problem here. installed ventura overnight and now can't continue with my work. downloaded fresh Xcode. no change. system requires 13.4.1 when I have 13.4.1

  • If you accidentally installed Ventura, follow these steps to uninstall: open Disk Utility and add a new volume to Macintosh HD (not a partition) Make a macos monterey bootable installer (Download monterey here: boot from the installer and install it onto the new volume during the setup process when asked to transfer files, select "From a mac or time machine backup" and select the ventura volume. After setup completes, you are good to go!

Add a Comment

You can launch it directly using /Applications/ file. Or via terminal open /Applications/

  • Is there any actual risk by doing this ? I mean why Apple is blocking Xcode 13 ? I understand that it make sense to requires you to have Xcode 14 for "some" reason but why blocking ?

  • I believe that there might be some issues with this Xcode, I don't know the exact reason why would they drop support for it. They did the same thing with Xcode 12 last year. However I haven't noticed any breaking bugs yet.

  • Via terminal I needed to just type in executable name, without "open", otherwise it opens me sublime text with the executable (like I double clicked on a executable in finder)

Xcode 13.4.1 is not working even from terminal: it says: The application cannot be opened for an unexpected reason, error=Error Domain=NSOSStatusErrorDomain Code=-10664 "kLSIncompatibleApplicationVersionErr: The app is incompatible with the current OS" UserInfo={_LSLine=3945, _LSFunction=_LSOpenStuffCallLocal}

  • It actually works. It didn't work on Ventura beta 1, but works on beta 2. Xcode 13.4.1

Add a Comment

It really can work via terminal command "open /Applications/" but not by directly launch app file method. You should make sure 2 things: 1. for having downloaded Xcode file and extracted to file, 2. for the app's location and name...are they actually same with terminal command mentioned above.

Hi, I had the same issue and what I did to resolve it is downloading the beta of xcode 14, it's like a beta thing, once I had Ventura's beta, I needed the xcode beta that Ventura supports in this url , there you have to click download in the top right corner and then search for the xcode14 folder and download it.

I hope this helps you too, and for me, I'm disabling the beta program to avoid this kind of problems in the future.

were you able to resolve this?...i'm having the same challenghe

I just went through this! Install "Xcode 14 beta 3" from here: and "Command Line Tools for Xcode 14 beta 3.dmg" from here:

Install Xcode 14 and then remove Xcode 13 with App Cleaner. After removing Xcode 13 drag Xcode 14 to application folder so it shows up in app drawer. Good luck!

This whole thing raises the point as to whether it is even worth running the betas at all if you're a developer. If you're a developer, you need to release your app to the App Store on a regular basis, and you can't do this with a beta. So why even bother testing it? I cannot take a four month vacation from releasing app updates, and dual booting is inconvenient when I actually have to use the machine, as I'd rather spend time using the OS I can actually develop from.

  • Apple clearly states on all of the beta pages that you must not use beta software on production hardware. Apple says you need to install the beta on a dedicated testing machine, not your main computer. So everything is actually working exactly as intended. Apple also clearly states you cannot use beta software in any part of the process for submitting apps to the App Store, so your builds will still be rejected even if you manage to use Xcode 13 on macOS Ventura because the latter is in beta

Add a Comment

same problem

There is a good reason for wanting to run older versions of Xcode. We recently had a regression in our app and I had to use git bisect to find when the regression was introduced. Without the ability to run the version of Xcode that was used to submit the app, I have no way to test an old release of our app.

I have tried the most common suggestion of running it from command line but no luck.

Command: open /Users/username/Downloads/


Xcode[3762:21719] [MT] IDEPackageInstallerHelper: Generic message for error: Error Domain=PKInstallErrorDomain Code=201 "An error occurred establishing a connection to the installation service." UserInfo={NSLocalizedDescription=An error occurred establishing a connection to the installation service.}

I'm unable to download and install command line tools separately. It complains about the macOS version.

I share the same sentiment as @zumacinsmity. On a regular day I support versions of the apps that are developed using older versions of Xcode. At least one major version older. In my case I was trying to install Xcode 13.2.1

  • exactly the same error as tulakshana. I have no issue downloading platforms and simulators under default Xcode 14.3, so don't believe there is any connectivity issue to apple servers. So not sure how to get round this error trying to run Xcode 13.2.1 under Ventura.

Add a Comment

Before running the open command I ran the following and I was able to use Xcode 13.2.1 in Venura.

sudo xcode-select -s /Users/username/Downloads/