Xcode 14 failed to prepare iOS 15.7 device?

An update to Xcode 14 appeared in the Mac App store today 2022-11-12. After updating Xcode from the App store app on my M1 MacBook, and plugging in an iPad, also updated today 2022-11-12 to iOS 15.7, Xcode says: "Failed to prepare the device for development".

A restart of both the Mac and the iPad doesn't fix this issue. Is there a way to get Xcode 14 to debug an 15.7 iPad? Or is a different build required?

There also is no 15.7 directory inside Xcode's iPhoneOS DeviceSupport directory.

Post not yet marked as solved Up vote post of hotpaw2 Down vote post of hotpaw2
11k views
  • I have same issue. XCode14.0(14A309) does NOT connect to iPadOS 15.7

  • LMFAO another 7gb download literally is so crazy and annoying every time ☠️💀

Add a Comment

Apple Recommended

  • Xcode 14.0.1 has support for iOS 15.7 and works for me (iPhone 13).

  • Instead of 7GB update just support files for 15.7 would been great

  • This is not yet available in app store. Since I have installed XCode via AppStore, what should I do?

Replies

Same issue but on an Intel MacBook Pro running macOS 12.6.

One would have hoped that today's Xcode 14 would support all of the versions of iOS and iPadOS also released today. Oh well. I guess we all need to wait for Xcode 14.0.1 or something. Can't wait to download yet another 7+GB Xcode release on my 10Mbps Internet connection.

  • $ ls -ad /Applications/Xcode-1*

    /Applications/Xcode-13.2.1.app /Applications/Xcode-13.4.app /Applications/Xcode-14.1.RC.app /Applications/Xcode-13.3.1.app /Applications/Xcode-14.0.app /Applications/Xcode-14.RC.app

    something gotta work in all scenarios ;^)

Add a Comment

Yes, I found the same question.

I am seeing the same thing as well, No issue on devices we updated to iOS 16 or devices still on iOS 15.6.1

I do have a directory for 15.7 in iOS deviceSupport though.

go figure....

same problem here, cant pari with 15.7 old iphone

Same for me here. Does this mean if I archive the app and release to Apple it won't run on a device with iPAdOS 15.7 - the latest Version?

i found a temp way to fix this. after install xcode 14, download xcode 13.4.1.xip. keep two version xcode. the xcode 13.4.1 now seems can work with ios 16 and ios 15.7 same as good.

  • The Xcode 13.4.1.xip worked for me. Download here: https://xcodereleases.com/

    Unzip it, launch it, connect the device. After it initialized the device, I was able to deploy to the iPad.

  • it's weird, I found no support for iOS 15.7 on Xcode 13.4.1 (13F100)

Add a Comment

Yes, I found the same question.

sigh

I really don't understand how this can happen. Unless Apple plans to fix this very soon.

Exact same issue with Mac M1 Pro, MacOS: 12.6, Xcode: 14, iOS: 15.7

Same thing here. It is quite amazing how Apple is utterly inconsiderate of small developers. It seems they've assumed that everyone is a big company with dozens of available devices at hand, at any time, with all iOS versions at the ready. Perhaps this is the same reason why Xcode is such a huge ***** and that app uploads to the store often fail at low bandwidths. They probably also assume that everyone runs on a fiber optic line or is a Cupertino resident.

+1

Waiting for Xcode 14 update. Hope it'll come soon because I need to test the app on a real device before uploading for customer.

+1 Same MacBook Pro 14"

Same issue with me.

Works for me: Start Xcode 14. Start Xcode 13.4.1. to prepare the 15.7 device; wait until it is working. Close Xcode 13 AND 14, but keep the device connected to the computer. Now start Xcode 14 again, the device is functional.

  • Also works on my MacBook Pro M1 Max. Still running Xcode 14 while Xcode 13.4.1 is preparing the iPadOS 15.7 device is not necessary.

  • Ditto. Simply having Xcode 13.4.1 prepare the 15.7 device (with Xcode 14 not running), then subsequently running Xcode, worked for me as well.

  • The workaround must be applied each time the iOS 15.7 device is rebooted.

Add a Comment

Same issue here. MacBook Pro M1 Max.

  • I'm also seeing this issue, a week later. How about providing support in the latest release of Xcode for the latest release of the various OSes? Crazy, right?

    Now if Apple could just make Apple Watch coding work reliably, with no witchcraft or rubber chickens, repeatably...

Add a Comment