iOS 16.1 or newer cannot manage sandbox user subscriptions from settings

Hi community:

When I try to access subscription settings, after filling in my sandbox user's password, a message "cannot connect" appears, just like below. Does someone know about a workaround to cancel or reset the subscription from the iPhone?

Thanks in advance

Post not yet marked as solved Up vote post of JesusMG Down vote post of JesusMG
1.9k views

Replies

Are you able to reproduce with iOS 16.2? If you can reproduce with any version, please generate a sysdiagnose and file a ticket http://feedbackassistant.apple.com

Add a Comment

FB12085191

  • Just reviewed your ticket, this is with iOS 16.1 please test with iOS 16.2 or later. Recommended now to use 16.4 and let us know if you see any issues. If so, a feedback ticket with a sysdiagnose is recommended. thank you. feedbackassistant.apple.com

Add a Comment

I have the same issue. I have been trying to manage my sandbox account on an iPhone 11, 16.3 but get the same error.

  • Can you try with 16.4 and let us know if you see any issues? if so, a feedback ticket with a sysdiagnose is recommended. thank you. feedbackassistant.apple.com

Add a Comment

Looking forward a solution/workaround, thanks for your attention

I just want to confirm, the issue described is with the Subscriptions page for Sandbox Apple ID's created in App Store Connect. Only those accounts can sign-in to sandbox and are visible in iOS Settings app under App Store. Tap your signed in sandbox apple ID > tap 'Manage' and then tap 'Subscriptions'.

While apps installed via TestFlight, the only Subscription management experience available is via the showManageSubscriptions function.

If you are experiencing issues access the subscriptions page with you sandbox Apple ID, please provide detailed steps, screen recording and a sysdiagnose - then reply with the FB# and we will review asap.

  • Yes it is. I attached a sysdiagnose and updated the ticket FB12085191 I hope it will be helpful.

Add a Comment

Hi @JesusMG, have you had any lucky with this? We are still finding this issue after upgrading to 16.5.1

Hi @JesusMG, have you had any lucky with this? I am still finding this issues on multiple different deices on 16.6

@App Store Commerce Engineer , any update on this?

Having this issue with TestFlight internal builds. (Worked fine in Xcode sandbox)

No updates