Stuck on Authenticating with iTunes Store


I'm preparing submission the app to app store, but I'm stuck on "Authenticating with Itunes Store" step and got error -22421.

I have check the cerificate and profile, there is no problem. And before uploading, i have validated the app, and it was success.

But when submitting always failed. Are there any solution for this case?

In some forums, like stackoverflow, they said the problem come from apple server. I dont know is it correct or not.

Any suggestion for this case?


I'm getting the same error, Xcode 8.3.2 (8E2002). Problem has only started recently, I successfully uploaded a build on Apr 23 of the same app with no problems.

Try this, it fixed it for me. Open Terminal and run:

cd ~
mv .itmstransporter/ .old_itmstransporter/

iTMSTransporter will then update itself, then you can try uploading in XCode again.

Thank you very much! This solved this problem at least for me!

Thank you so much. It worked for me.

It helped me with the upload phase.

But still the App doesn't show on AppStore.

Kind regards Thomas

Thank you so much. It solved the issue for me as well. 🙂

Wow, that's great. It works now.

Thank you.

Wow this fixes the issue on my machine too. Do we know what is the root cause? Toolkit update failure?

Thank you very much 🙂

Updating iTMSTransporter works for me to. thank you.

Solved the problem, Thank you so much !

After doing that, I have submitted my app from Application Loader and it works! Many thanks. But from Xcode, now I cannot submit nor validate.

This worked for me as well

It worked, Thanks a lot 🙂

please make it more searchable ( like provide it in stackoverflow ) this is so helpful