10.13 MBP won't sleep/wake

When I put my MBP to sleep via menu bar or diaglog box(hold power for 5 secs, click "Sleep") it will go to sleep and wake up properly. When I close the lid or walk away from my MBP it will not wake. It will not wake becuase it has actually not gone to sleep. The SIL(sleep indicator light) will come on once sleep is indicated. It will not breathe, just solid on. When I open the lid it does darken a bit, like it's about to come back, but it won't!

Seperately the console app won' open so I can't get at the logs easily.

Machine: 2011 13" MBP 16GB/525SSD dirty install from 10.12

Accepted Answer

I was able to get this working again uing terminal.


In terminal:


pmset -g custom


Look at 'hibernate' mode and 'standby"


Hibernate mode should be '3' and Standby should be '1' (my standby was set to '0')


Change 'standby' to '1' using - sudo pmset standby 1


My MBP now correctly goes in to standby when closing the lid and wakes when opening it.

Answers

I've got the same problem here ! On macbook pro mid 2010 8 GB/SSD 500gb

Same here, MacBook mid 2010 8GB / 250 SSD

hmm so far all 2010/11 MBP, 13? 15? 17?, do we all have SSDs? I do, 13". Can anyone get their console app to work?

Just tried:
SMC Reset

PRAM RESET


Tried it from the login window:

Sleep icon works

Closing lid does not work.

13" here aswell, and I can't open the console

15" MacBookPro Early 2011, OWC SSD, closing lid doesn't put totally to sleep. Find it super hot and unable to wake.

Simlar here on 2010 MBP i7 15", if it goes to sleep it won't wake up.


No problems on new Mac Pro 2013 waking up.

Yep Console working on 2010 MBP i7 15" (no optical and 500 GB SSD), Maps ins't though, just something that looks like garbaged b/w video only.

Same here - plus it gets pretty hot when it should be nice and chilly as it's asleep...


Mid 2012MBP

Late 2011 15" MBP 8GB/250SSD upgrade from 10.12 formatted to APFS

Console is working.

Sleep only works when going to Apple->Sleep then closing lid, otherwise same as everyone else.

also, of topic but iTunes music sounds distorted

Same issue with no sleep from sliding the lid/not being able to wake up. I also WAS not able to open Console - this one I was able to resolve with the following: 1) Remove release version of Xcode.app 2) Install developer beta version of Xcode 3) Ensure that Xcode command line tools are set for the beta version from within Xcode pereferences 4) Optionally reinstall release version of Xcode from MAS

I should also note that despite having Consolr working, I still have not found any clues to the sleep/wake issue. I’ve also noticed that automatic graphics switch does not work, my dedicated graphics are running full time. Late 2011 15” MBP

I was able to get this working again uing terminal.


In terminal:


pmset -g custom


Look at 'hibernate' mode and 'standby"


Hibernate mode should be '3' and Standby should be '1' (my standby was set to '0')


Change 'standby' to '1' using - sudo pmset standby 1


My MBP now correctly goes in to standby when closing the lid and wakes when opening it.

confirmed for me that this fixes lid sleep/wake. THANK YOU! Late 2011 MBP 15". Now we just need a fix for constantly running dedicated graphics card...

I made this change to my late 2011 MacBook Pro. It appears to be going to sleep, but it still does not wake.