Disk not ejected properly

Since upgrading my iMac to High Sierra Beta I somtimes got the 'Disk not ejected properly' from my Thunderbolt 2 raid (still HFS filesystem).

After now connecting my USB 2 external disk to back up after about a minute or two it started to constantly connect and disconnect (Hole list of "Disk not ejected properly" in notifications).


Connecting both disk to my Sierra MacBook Pro does not show this behavior. Any idea what is triggering this?

Post not yet marked as solved Up vote post of nicolask Down vote post of nicolask
61k views

Answers

Hi there!


I had the same issue but with the final Release version. I had to reconnect my thunderbolt 2 drives with USB to get them to work properly.

Seems that the thunderbolt device framework has some issues....


Regards

I'm experiencing the same. After updating to High Sierra 10.13 I'm constantly getting "Disk not ejected properly" alerts with my Seagate Backup Plus external hard drive (directly connected to USB port on my MacBook Pro) - not only when I wake the system up from a sleep state but even while I'm actively using the computer.


I use the external hard drive solely for Time Machine backups so these alerts are very frustrating!


Any idea how to fix this?

This is a suggestion, something I have tried and that seems to work for me. Go to System Preferences/ Energy Saver and uncheck "Put hard disks to sleep when possible". Try it for awhile and see if you see any improvement.

It seems that Apple and Microsoft can't get their USB and Thunderbolt drivers to work right. I had a whole slew of error -36 problems when 10.12 first came out. After the second update, it seemed to stabalize. Under Windows, I can't use two of the exact same USB drives on the same computer (it loads, then ejects the devices, rotating betwixt the two drives, over and over and over and over).


I would bet that USB and TBolt use a common library and that library has issues. From past experiences, don't expect Apple to acknowledge this issue, nor address it with any urgency (it's ONLY you're data, right?). If you have a USB device you are currently using as a backup device, I would stop using it until the issue is resolved. If you have a backup device and there is another Mac on the same network, I'd transfer the device to the "properly working" Mac and then access it via File Sharing. It's slower, but infinitely safer than improper disk ejects.


One saving grace is that the Mac file system is "journaled" and has a much better chance of recovering from a disk error than any Windows system.

Hi there!


Thamks for the info, but unfortunately I never had this checked in the first place.

I remember that they had the same issue with the 10.12 release in the beginning...


QA in macOS isn't anywhere the standards it once was, pity :-(

I'm experiencing the same behaviour.

Macbook Pro 2016, High Sierra, USB external 2.5" hard drive (not native USB-C - connected via an adapter). After I put computer to sleep, after waking up, I get the notification about disk not ejected properly. Also, the drive automatically reconnects (I get a password prompt as the drive is encrypted). Macbook is connected to external power. It happens regardless of the "Put hard disks to sleep when possible" setting.

I've been noticing the exact same issue randomly on my 2016 macbook pro when my Seagate Backup Plus USB hard drives are connected.

All of a suddent the "disk not ejected error" pops-up. Even when the drive is not even physically moved by me. And then the hard drive re-connects automatically after a few minutes and re-appears on the desktop.

Can at least Apple's tech support team assign someone to look into this issue and let us know about a status update gradulally?

I am having the same problem. I installed 10.13.2 today (upgraded from 10.9) on my Mac Pro (2013 6-core). The drives in my thunderbolt RAID mount ok but are usable for only a few minutes. After about 5 minutes or so, for no apparent reason, I get a ' Disk not ejected properly' notification and they disappear regardless of whether I am using them or they are sitting idle. I can only get them back mounted by restarting the system. These are the main content drives for a commercial post-production facility so having them randomly disappear is a HUGE deal - not a minor issue. I checked to see if there was any sort of firmware update or other hardware issue with my RAID and everything looks ok there. Suggestions?

Just chiming in to say i'm having similar issues on my 2013 Mac Pro (the Bin Pro). I'm having external HDD's eject midway through work regardless of the 'put hard disks to sleep' check. Once they eject, they have issues recognising the hard drive again.


I've got an appointment with apple store tomorrow to get my I/O board and Logic Board inspected, as i've been told by multiple apple employes that it's going to need replacing.


This thread has given me some hope that it's a software bug rather than a hardware issue with me.


My bank is hopeful as well..

i'm running a 2013 Mac Pro on 10.13.2 also and having idential issues. It's completely halted my work flow. I've been in touch with apple support, and they're telling me i'm likely to have a faulty logic board, or a faulty I/O board. But seeing other people with the same issue, sounds really really unlikely.

Thanks for posting in here though, you've given me some real hope here.

Apple REALLY need to sort this, this is my busiest time of year for work, and i'm completely static.


EDIT: i'm going into an apple store tomorrow to get the mac inspected to see if there is any issues. Will report back

Thanks. The RAID worked flawlessly on OSX10.9 right up until I updated the OS yesterday. If it was a hardware problem it seems that the issue would have shown up earlier. Doesn't seem a likely coincidence that the hardware just happened to go bad on the same day I upgraded. Seems like it's something related to 10.13.2. Will be curious to see what you find out at Apple store.

yeah it's far too coincidental for multiple people to have an identical issue, on the same OS build. I'll let you know how it goes, but what i'm planning to do is to wipe the machine, downgrade to Yosemite (i think the pre-installed OS), and then try my hard drives and see if that fixes it.


It's worth noting that i'm not using a RAID system, i've just got a 2tb USB HDD and a 5tb USB HDD, both of which eject at the same time.


Also, when i ran a self diagnostics test on the machine, it came up telling me there was an issue with the thunderbolt hardware, maybe it's worth trying this on yours and seeing if you get a similar response?

Same problem here. 10.13.2, iMac 2017 27"


So far, have only seen problem on USB. Has trashed backup on drive once. Was hoping to try Thunderbolt, but from this useful forum it looks like that this might be problematic too. Apple need to address this as a matter of priority.

went into the apple retailer i was recomened to by apple today. One of th emost useless experiences of my life, had a guy that had never seen a Mac Pro before in his life, so was too scared to take a look at it, or even power it on. He simply told me, if i wanted anything looked at, it'd have to be sent away for £50, just plain refused to discuss anything with me.


So i'm going to try and downgrade to Yosemite, or whatever OS this came with, then i'm going to see if the issue persists from there. Wish me luck, gonna be a long few days

I'm not a developer but found this thread via google for the same problem. Just bought an iMac 2017 27" running 10.13.2 and set it up 3 days ago. I have a burly system of external drives connected via USB3. At first the drives were just ejecting randomly whether the machine was sleeping or in use. I unchecked 'put hard disks to sleep' and that solved some of it. Now they stay mounted consistently except when I put the computer to sleep - then they all dismount and I get the error messages that the drives ejected. Overnight they have ejected and remounted themselves up to 6 times as I will have 24 error messages to close in the morning but not now that I only put the display to sleep.