Apple Mail Forces Sign In Gmail

10.14.4 Beta (18E174f)


Apple mail keeps asking for sign in and passwords for my gmail accounts and others.

Post not yet marked as solved Up vote post of hasbeen Down vote post of hasbeen
12k views

Answers

Same is happening to me. Do you sync those accounts' info with iCloud? Are you seeing any warnings in Sys Prefs for iCloud needing to update settings? Wondering if keychain is getting crunched somehow

Same with me.

Same with me, additionally affecting other machine running Mac OS 10.13.6 (17G6006) that is iCloud synced, after updating other DEV machine to 10.14.4 b1

bug submitted — #5230946

It has ground me to a halt. I have about six gmail addresses that I monitor in Mail App including my G Suites front end. A couple of them work consistently without a problem, but most of them seem to sign out randomly and require me to log in again and again. Some refuse to validate until after I do a full shut down and start up, after which I still have to re-sign in, but then the work for a little while.


I have comved through the gmail settings and all seem to be set the same way. So, I am nonplussed re a workaround.

I have an old AOL account that Mail cannot stay logged into for more than a few minutes. If I create an app specific password, that fails.
All accounts work fine on the iPhone.

Yup Me too


I sent a bug report, lets hope there is a quick release to fix this thing

I found a workaround, if anyone is interested.

Its ugly, but if youre like me and you rely on your gmail account, it will get you by until the next update.


Log into your gmail account, and go to your account settings; select "Security" on the left.


Allow less secure apps.

:/


Go back to your mac, go to internet accounts, and delete your gmail account, and then add a new mail account by clicking "Add other account," then "mail."

Fill in your gmail information and this should bring the account back, But be sure to go back to the other way when the next beta comes out and hopefully this issue is resolved.

fwiw, a downgrade back to Mojave 10.14.2 (then the official 10.14.3) has worked for me without any hiccups.

I'll re-install a future Mojave 10.14.x beta when the gmail 2FA bugs get worked out.

I actually just turned off keychain in iCloud sync - kept the local copy - and they all started working magically again.


*UPDATE* Persisted through reboots

Tried this but so far does not work.

My settings were aIready "less secure" on gmail, and iCloud keychain already turned off to prevent my Exchange accounts from disappearing, still no joy.


So I too had to downgrade to 10.14.3.


I like to keep the betas running on my daily machine to help coax out the bugs, and it's alwayts an adventure to work around them and watch them get worked out, as well as to see innovations as they're rolled out.


But this one was just too much of a problem with daily tasks. 10.14.3 works perfectly though, including the old AOL account.


I will be back on the betas as soon as serviceable though!

update update - yeah, it's back 😟

10.14.4 Beta (18E184e) seems to have fixed this.

10.14.4 does NOT fix the problem.


A similarly frustrating problem is occurring in BusyCal, although somehow Apple Calendar is able to sync to Google.


UPDATE:


10.14.4 beta 2 DOES fix this.


Thanks, Apple!

I'm seeing this problem again today on 18E220a (10.14.4 beta 6). It asks to signin on each account, oauth seems to proceed correctly, but it fails to connect to the accounts or open the email boxes. Currently seeing this on all google apps accounts (with custom domains) but not on my @gmail account, which is odd.