Universal Links not working properly on iOS 13

Universal Links was working fine on iOS 12 but I ran into issues when I updated to iOS 13.1 yesterday.

URLs that's supposed to open the app when tapped are just opening up in the browser.

Some users on iOS 13 reported the same thing.


I believe AASA file is not being downloaded properly. I tried tapping on Open from the banner that appears on top of Safari when I land on one of my urls. This didn't help.

Sometimes it worked fine after few re-installs and reboots but when you re-install again it stops working.


I exported sysdiagnose and my swcutil_show.txt shows this for my app


Service: applinks App ID: (my app ID)
App Version: 102 
Domain: (app.myurl.com) 
User Approval: unspecified 
Site/Fmwk Approval: unspecified 
Flags: 
Last Checked: 2019-09-26 00:48:24 +0000 
Next Check: 2019-09-30 23:51:38 +0000


while other apps (Apple News app for example) looks like this


Service: applinks App ID:  ZL6BUSYGB3.com.apple.news
App Version: 2300.5 
Domain:  news.apple.com 
Patterns: {"/":"*"} 
User Approval: unspecified
Site/Fmwk Approval: approved 
Flags: systemApplication 
Last Checked: 2019-09-25 18:45:50 +0000 
Next Check: 2019-09-30 17:49:04 +0000


For some reason it's missing the Patterns (from AASA) and Site/Fmwk Approval is unspecified.

I also tried exporting sysdiagnose when universal link was working after several reinstalled and reboots.

My app did have something for Patterns with Site/Fmwk Approval approved


Right now I am confused as it seems like this is happening randomly.

Last night I reinstalled/rebooted the app and non of the urls opened my app This morning I reinstalled/rebooted the app several time and now the url is opening the app every time.

Post not yet marked as solved Up vote post of dltkdals92 Down vote post of dltkdals92
53k views

Answers

I am facing the same issue. Did you get it worked some how?

Assuming you are supporting all paths in your domain, try setting path in AASA as -

"paths": ["NOT /e/*", "*","/"]

Hope this helps

I have the same missing "Patterns" field for our app on iOS 13.1:

Service:              applinks
App ID:               TeamID.BundleID
App Version:          1.0.0.0
Domain:               my.domain.com
User Approval:        unspecified
Site/Fmwk Approval:   unspecified
Flags:               
Next Check:           0001-01-01 03:26:23 +0000

for specified "paths": ["NOT /_/*","/*"] in .well-known/apple-app-site-association

Also, I have noticed that some other apps are missing "Patterns" too and have "Site/Fmwk Approval: unspecified" on the same device.

They have specified some "paths" in .well-known/apple-app-site-association file, but I haven't succeeded to open any of them in the corresponded app instead of Safari.
Filled the bug report 7340740 in Feedback Assistant.

I am also facing this issue. Any ideas on how to fix this?

Would you mind posting your AASA file URL? I am also investigating this issue for my apps.
One thing I notice the difference is the hosts accepting http/1.1 working fine ("ALPN, server accepted to use http/1.1") with compare to the ("ALPN, server accepted to use h2").

In my device, lot of domains are failing to load the AASA files and randomly checking on the patterns using curl command, I find the same difference. May be some hint for all of you who are investigating this issue. In case you find any solution please do reply here.

This is happening with our app as well as the apple AppStore and Instagram and probably all apps.

Yesterday I had it take me to Safari for my app and the Banner Link at the top was for the Apple Store app! (Not the AppStore app)

Something is very broken in ios 13 regarding universal links.

We had the same problem, and our server served the content over h2. After changing to http/1.1 it started working also for iOS 13 devices! Thanks for taking note of this quirk.

I'm using http2 only and was having a problem with univeral links on iOS 13.1.2 on my iPhone, but not on iPad. I re-installed the app on both iPhone and iPad. iPhone - no go, but links worked again on iPad. After restarting iPhone and re-installing the app universal links started to work. Just sharing my experience here. Having to tell customers to restart iPhone and re-install the app is not optimal of course.

Same problem here and try all the way that the post said it might make work again by restart and reinstall multiple time. No luck always stuck with Safari and need to pull down to see the open from app. no way to get to the app directly anymore.

Any suggestion????

You can use this to debug:
https://ios13.dev/universal-links-debugging-on-ios-13-cjwsux93w001p6ws1swtstmzc
looking to my report I can see that exist "Next check"

Service: applinks

App ID: ---------.com.---------

App Version: 16

Domain: ----------.com

Patterns: {"/":"/---------test-server/idverification/"}, {"/":"/--------server/auth/verify/"}, {"/":"/-------server-qa/idverification/"}, {"/":"/--------server-qa/auth/verify/"}, {"/":"/------t-server-dev/idverification/"}, {"/":"/-------server-dev/auth/verify/"}

User Approval: unspecified

Site/Fmwk Approval: approved

Flags:

Last Checked: 2019-10-08 14:42:21 +0000

Next Check: 2019-10-13 14:37:19 +0000

Hi,


We had the same problem, but after upgrading to iOS 13.1.2 or (iOS 13.2 Developer beta) the bug automagically disappeared.
Thanks Apple for being so polite to let us know in this thread.

Hi,
We have same problem. In the Safari universal link doesn't work only forwards to the store.
But in the Notes or iMessage it works.
Aslo https://search.developer.apple.com/appsearch-validation-tool/ we cannot past verification. But it worked before iOS 13 release.

Hi,


We are also facing same issue for one of my new APP, Universal links worked fine in iOS 12 after upding to iOS 13 it stopped working.

Currentky running with iOS 13.1.2.


Tried above solutions mentioned by other users but it didn't worked out.


apple-app-site-association downoding automaticlly when app installed in simulator for iOS 13 but not even attept when app installing in iOS 13 device.

This has been happening to me as well since updating to iOS 13.


In iOS 12 everything works fine.

Same issue here.