App not displayed in Settings App

Whenever I fresh install my app onto my device, it is not showing up in the Settings app. Even after trying to search it, nothing appears.

I use location services and local network within my application so I need to be able to change those authorizations as it does not reliably prompt for those authorizations (I need always for location and that was removed, local network never prompts correctly).

I have however seen my app appear in the settings app under privacy -> Location Services but not local network. Is this an issue with Apple or with my application?

Should also be known that it does appear in settings on some devices.
  • Did this ever get addressed? I'm adding iPad compatibility to my app, and while it's always shown up in Settings on the iPhone it's not on either iPad I've installed it on. This is a real problem when I need to direct the user to authorize Location access.

Add a Comment


Hey Jacob,
I have a few more questions about your issue.

  • Is there a .bundle file in the Xcode project?
  • What devices do the settings show up on?
  • What iOS version does the device in question currently run?
  • Have you restarted the device?

Hope to hear back from you,
Hey Mateo,
  • There is no bundle file

  • Shows up on iPhone 8 64GB(Mine, not my coworkers), 2017 iPad 9.7" 64GB, and iPhone XS 64GB

  • This particular device (iPad mini 5) that is not showing is running 14.0.1 although I know it's happening on other devices as well. My coworkers device that isn't working is an iPhone 8 64GB was on 14.0.1 when first discovered problem. Problem persists on 14.1

  • Yes. Restarted, fresh install, reset all settings. A lot of things.

  • how did you resolved it?

Add a Comment
I am experiencing the same with my TestFlight build, was there any solution to this?
Add a Comment

Experiencing same bug in my new iPhone SE (Just Purchased), installed with latest iOS version 14.6 Whereas in my old iPhone 6S, it's working fine.

Apple must fix this issue, as its really annoying. I've added location permission, which I accepted and now I can not change it. App installed directly from Xcode and tried also with TestFlight. Tried everything related to device, like killing the app and fresh start again. Device turn off and on again.

Has anyone filed a bug about this? If so, what was the bug number?

Share and Enjoy

Quinn “The Eskimo!” @ Developer Technical Support @ Apple
let myEmail = "eskimo" + "1" + "@" + ""

  • I have a similar issue. The App Review team also ran into this problem when reviewing one of my apps. Created feedback FB9761108.

  • Ta!

Add a Comment

I have the same problem. I install app through xcode and testfight. Device: iPhone13Pro(15.0.2), iPad6(15.0) Restart Settings not work. Restart iPhone not work.

  • I fix it. I change the bundle identifier, build an app, then I change the bundle identifier back, build again, done. I suppose it's a cache bug, change bundle name clear the cache some way.

  • This work for me.

  • this work for me as well

Add a Comment

Quit Apple Account fix the bug for me.

I was using CloudKit. The app appeared in the Settings app only after the app accessed CloudKit through:       [[CKContainer defaultContainer] accountStatusWithCompletionHandler:^(CKAccountStatus accountStatus, NSError *error) {

That makes sense. Try to use the function that requires some sort of permission suitable for inclusion in the Settings app

I fixed it by cleaning a build folder and rebuilding the app. I guess it's connected with cache in some way.

Shortcut: Cmd + Shift + K

I got the same issue when I ran the app on a device that doesn't have a SIM card. I show up local network permission alert on app startup and if it is denied by the user the first time there is no way the user can change that in the settings as the app is not available there. Even the app is shown in Privacy & Security -> Local Network but not in the settings list. I tried cleaning the build folder, restarting the device etc.

I had a look at the bug mentioned upstream (FB9761108) and there’s been no progress on it. If anyone else has any bugs filed about this issue, please post the numbers here.

I’ve encountered problems like this myself, but I’ve never managed to work out the root cause )-: My standard workaround is to give my app a dummy Settings bundle. That causes it to show up in Settings regardless of any of the other settings that might be relevant. I usually just populate my Settings bundle with a single item that shows the app’s version.

Share and Enjoy

Quinn “The Eskimo!” @ Developer Technical Support @ Apple
let myEmail = "eskimo" + "1" + "@" + ""

My Xcode Version 14.3.1 (14E300c)

I've been encountering this issue for a couple of days, but it's only happening with new Swift and SwiftUI projects. To generate the plist file, I add a new URL Types, which creates the info.plist file attached to the target info.

After that, I clean the build folder, close the project, delete derived data, and reopen the project. However, after running it, I can't seem to find the app's info. In my case, I'm dealing with location privacy permissions (Privacy - Location).

The app prompts the user correctly to allow location access, but after making the choice, I can no longer modify this value from the app settings.

Of course, I've restarted my phone and Mac countless times.

If I create the project with Objective-C, I don't encounter any issues. It appears to be an issue related to Swift and SwiftUI projects.