No service or cellular data after ios 14.7.1 update

I updated my software to 14.7.1 recently and lost my cellular data completely.

i have tried all the trouble shooting steps and still cannot get it to work

  • restart my phone (couple times)
  • reset network setting
  • insert new SIM card
  • called my carrier (Tmobile) to refresh on their end

anyone is experiencing the same thing?

Post not yet marked as solved Up vote post of Redbean012 Down vote post of Redbean012
7.3k views
  • Me too in my new iPhone 12 mini's iOS v14.7.1 (I didn't check before the upgrade) with VZW. Old iPhone 6 + don't have this problem. :( Weird that an iPhone 11 Pro Max's iOS v14.7.1 didn't have this problem. Confused!

  • me too iPhone 7 since over 4 WEEKS ! ! ! ! ! ! ! !

  • Interesting. I got a Verizon Wireless carrier update and my cellular signal is better now? We'll see.

Answers

Same here. iPhone 8 Plus.

Setting's screen 'Cellular' is blank.

Same here. iPhone X iOS 15 beta

Woke up to ‘No Service’ about 2 weeks ago and still. Was starting to think it was just my phone.

tried everything. Still.

Same here with iphone SE ...

I have an iphone 11 and a iphone 12. Weirdly, this problem is only in the iphone 12.

perfectly working 7S - updated to 14.7.1, now it's a paperweight went to the apple store, your phone is dead, but we can sell you a new one for $700 maybe it's time for an android

Same here with my iPhone 8

Me too with my iPhone 12 Pro.

Same Here, Iphone 12 Mini. I don't dare to update my old iphone XR now. The Stupidest thing is , I don't find the IOS pack to downgrade my IOS back to 14.6.

QRIS_M: You can't downgrade iOS versions. :(

Hi! Encountered this with an iPhone 12 Pro, that updated to 14.7.1 via WiFi. We were able to solve it by updating to the latest Mac OS version [Latest Big Sur] plugging it to the Macbook Pro. And in Finder, clicking Restore iPhone. Before doing this I backed up all the photos and videos to the computer and also the contacts to ICloud.

The iPhone booted to it’s original welcome screen and cellular was already working with the icon showing a signal. It asked for passcode verifications, Apple ID. And tada it booted normally.

I am also having the same issue on iPhone 8 Plus. To get rid of "No Service" I restored the device to factory setting and now it wont activate.

I read iOS v15 beta fixed it? Has anyone tried it yet?

  • I’m using the latest public beta (iOS 15 Public Beta 7) and still “No Service” 🥴

Add a Comment

Me too with my iPhone 11 Pro max.Anyone with the solution?

Ooh, iOS v14.8. I wonder if it will fix this issue. I'll find out later today after I do a back up and upgrade. Did anyone try it yet?

  • Nope. V14.8 didn't fix it. :( Maybe v15?

Add a Comment

Just updated my iPhone XS to the iOS 14.8, and now I have lost the cellular data (No Service) as well, never had such an issue. I have tried everything above, nothing helped!

Additionally, I have an iPad Pro 11inch 2nd generation which has been also updated to the latest iPadOS 14.8, tried to use my sim with it and it has the same issue, No Service

  • Replacing to the completely new sim, fixed my problem.

Add a Comment