'Disable Caches' no longer on the Develop menu in Safari 11.0

There used to be a 'Disable Caches' option on the Develop menu, but it's no longer present in Safari 11.0.

It's very useful when developing not to cache the response from web servers. Is this an oversight?

It seems the only option now is to use ⇧⌘R in web inspector.

Accepted Reply

On Apple Release Note on Safari 11.0 there is this point:

Removed the Disable Caches menu item in the Develop menu. The equivalent functionality is now available through Web Inspector’s Network tab.

Then, option was only moved to another section 😉

Replies

Same here. This is a big deal. I contacted Apple and this option has been removed, with no workaround... I sent feedback to Apple, hoping for a solution.

Interestingly, in Safari --> Preferences --> Advanced, if you click on the question mark in the lower-right-hand corner, scroll down to the bottom and click on the "Use the Safari Develop menu" link, about halfway down there is a description for the Disable Cches option that states: "Retrieves a subresource from the web server each time the subresource is accessed, rather than using a cached copy."


So hopefully the option was removed from the menu accidentally.... hopefully....


[This was in Safari Version 11.0 (12604.1.38.1.7), which I installed just a few moments ago.]

On Apple Release Note on Safari 11.0 there is this point:

Removed the Disable Caches menu item in the Develop menu. The equivalent functionality is now available through Web Inspector’s Network tab.

Then, option was only moved to another section 😉

This helped thanks. Now. Are caches disabled when it is blue, or grey? Not clear...

Since the tooltip says "Ignore the resource cache…", I assume blue means caches are disabled.

this is super annoying


APPLE please give us back the old "IGNORE CACHES"

You want to disable caches? You must be crazy! They don't even want to let you turn off Wifi! 😁

Hi

I dont find ...this that means we need open dev console ?


Thanks


oh i find it this is really annoying to not have at least the status of this fonction in one of the browser menu...

PLEASE!!!! Bring it back "DISABLE CHACHES" to Develop menu!!!!
PLEASE!!!!
PLEASE!!!!
PLEASE!!!!


Why Apple doing so?? Why?? It was very useful, what developers was thinking about when removed that useful option??????

While you have the Web Inspector open, try one of the following:


1) click on the 'Network' tab, on the top-right of the tab there is an icon with a tooltip that says 'ignore the resource cache when loading resources'. Click on it - turning it to blue - to activate 'ignore cache' mode.


2) if you hover over the 'Reload' icon in the Web Inspector toolbar, you'll see a tooltip that says: "Reload Page (⌘R), Reload Ignoring Cache (⇧⌘R)". So, you can reload a page, ignoring the cache, by pressing Command+Shift+R on your keyboard, too.

Disable cashe from within dev tools does not work if a reasource is selected!, PLEASE bring it back as before!

On the network tab, is the button with the little pill icon with a curved arrow over it equivilent of disable/enable cache?

It says "ignore the resource cache / use the resource cache"

https://image.prntscr.com/image/EL6EP6khRyC8ZKTIU-XGeA.png
Disable cache doesn't work. I checked blue button on network tab, pressed cmd+shift+r and got cached .html files (see screenshot).

I think the shorcut is wrong. cmd+shift+r didn't work for me, but cmd+alt+r did.

Well, this *****, mainly because the icon on devtools DOES NOT work. Never worked for me. I'd rather the empty caches on the develop menu. At least it worked. Now I'm stuck with Chrome for development