com.apple.DiskManagement.disenter error 0 on external drive

com.apple.DiskManagement.disenter error 0 on external drive

anyone know how to get to the hard drive?

Post not yet marked as solved Up vote post of cycleduck Down vote post of cycleduck
51k views
  • My external ssd (Apple 251GB, APFS formatted) doesn't show up on the desktop. It is visible in Disk Utility but I can't repair, erase or split it. Does anyone have advise for this issue?

  • Hi, I fixed this issue.

    Some older MACs wont mount if the allocation size is larger than 1024. So to resolve this, go to a Windows or Linux machine (if you have one) and reformat the **** in ExFAT and select 1024 as the allocation size. Worked for me, hope this helps :)

Add a Comment

Replies

Nevermind, figured it out myself
  • Thanks @jkrosado, it was exactly as you said. Thank you very much!

  • hi @jkrosado could you please explain more clearly what to do on Mac ? same thing happening with my hard drive :(

  • In my case when I try to mount the hard drive it says com.apple.DiskManagement.disenter error -119930868 Does anyone know who can I solve this problem?

Add a Comment

Arguably, "figured it out myself" is not a very helpful answer to a situation like this, as people looking for answers reach a dead end.

Anyways, if your disk happens to be ExFAT, and you remember improperly removing the disk the last time you used it, chances are, fsck is holding it hostage (metaphorically, of course). fsck is trying to repair the disk, but it will stall forever, so you want to launch Disk Utility, and the Terminal. Try to mount the disk, and switch to Terminal and write sudo pkill -f fsck. The disk will mount in read-only mode, and from there, you can repair it with First Aid in Disk Utility. This won't work for non-ExFat drives, as macOS manages them differently.

  • Thanks. That is EXACTLY what I needed to know to resolve my problem. Thank you jkrosado!

  • This is exactly what I have been looking for. Thank you.

  • Is there a different command using the zsh shell? I am trying to get a 5Tb external drive to mount in Monterey. It worked in Big Sur before I upgraded. Disk Utility keeps giving me a "disenter error 0"

This solved my problem thanks. Just a note to future users, the repair took a really long time for my 5TB drive. Be patient.

  • Thanks jkrosado, it worked on a mid 2012 MBP upgraded to macOS Big Sur using the "Patched Sur" app. MBP works great so far.

  • It took too long time for me too, I was going to kill it, but then I saw your comment and knew there's nothing wrong thank you

  • Thank you @jkrosado, this helped me, too.

This happened for me on a Big Sur MacOS, clicking the 'First Aid' option in Disk Utility kept giving me this same error. What ended up working for me was restarting my laptop, then continuously trying 'First Aid' until one time it suddenly didn't give me the error, and after waiting about 20minutes the drive mounted properly. I don't think I did anything differently other than trying over and over again.

  • It would be helpful if the Disk Utility told you that fsck is running. You can check with the command:

    ps -fu root | grep fsck

Add a Comment

Thanks jkrosado!

Thanks @jkrosado

Add a Comment

Thanks @jkrosado

Thank you for posting the fix. It worked and saved my years of work

-- Vishnu https://www.YinandYang.studio

Just to note to @jkrosado instructions: it worked with Mac OS Extended drive format too.

@jkrosado tysm!! it worked for me and saved me from panicking due to all my homework and software I need for my classes in that hard drive

This still isn't working for me. I don't understand what this "and the Terminal" means. When I try to mount my drive, the error that is the title of the forum comes up and it appears I am at a dead end. I tried to repair the drive, and it seemed to do something (with a bunch of green check marks) saying it was fixed, but it still won't open or be recognized by my finder or desktop. If anyone is able to walk me through this, I would be very appreciative.

  • Same exact issue for me here as well. The Terminal is a command line system that allows you to make changes to your computers OS. I ran the command Jkrosado posted but got nowhere with it.

  • Ok so first hit Command+Space this will pull up Spotlight. Then search and open Disk Utility. Now open Spotlight again (Command+Space) and search for Terminal and open that. Now that you have both open I suggest in Terminal type the command he listed above sudo pkill -f fsc BUT DO NOT HIT ENTER YET!!! Now in Disk Utility click on the drive that is not working along the left hand side and then along the top of the window click on mount. At this point you will not see anything happening that's ok, it's working in the background. Switch over to Terminal and now hit enter for that command you typed in earlier. This will kill the stuck process that you just ran in the background which is the issue. You will get two error pop ups, acknowledge through them. At this point you can close out Terminal and on Disk Utility along the top you can click First Aid and run that. It will take a while depending on how large your drive is and what not. Let it run and you should be fine. Let me know if you have any further questions.

  • I tried and failed after the first aid. the error message is as follows:

    First Aid process has failed. If possible back up the data on this volume. Click Done to continue.

    Any thoughts?

I also got this working on my HFS+ drive. Worked exactly the same as an ExFAT not sure what the technical background on this is but for those wondering.

Thanks @jkrosado Your answer was helpful. Drive should be ExFAT and it worked after killing process and first aid.

Thanks!

What about Mac OS Plus drives ? How can I solve it?

  • I’m pretty sure you’re referring to HFS+ format. If so then yes. See my comment above.

Add a Comment