USB hub failing under Monterey

Anyone seeing trouble with external USB hubs after installing the Monterey developer beta?

I have an ikling FX-1940E hub that I've been using with my M1 MacBook Air. Everything worked fine under Big Sur, and still does on another machine still running Big Sur, but I can't connect a trackball or keyboard via the hub's USB 2.0 or 3.0 ports to the Air since installing Monterey. The hub's VGA port still works on Monterey; I haven't been able to test the other ports yet. Also, a different hub (with fewer ports, so it can't simply replace the ikling) does work.

I've reported the issue to Apple using the feedback assistant. Any suggestions for anything else I can do at my end?

Post not yet marked as solved Up vote post of eurobubba Down vote post of eurobubba
  • Hi,

    After upgrade to Monterey, latest public beta (21A5506j), PD over usb-c from my monitor (Philips 346P1CRH/00) doesn't work as well.

    Apple please help!

  • Looks like most comments here are with MacBook and the M1. I have a been running a duel monitor set up with my MacBook Pro (intel) for years without issue on the MacOS Beta program. It wasn't until I just upgraded to release 8 that the monitors are no longer detected. I have not been able to find a workaround so any help would be appreciated.

  • PD (Power Delivery) over USB-C also stopped working on my MBP 2018 after updating to Monterey (12.0.1). I use a Philips 346P1CRH. Everything was working flawlessly with Big Sur.


Hej Together,

I have the same issue with my MBP M1 2020 connected with an external Monitor HP S340c. Power Delivery (PD) and Video-Connection not working (but Mouse and Keyboard is still supported/working).

I have opened another Thread (due to lack of knowledge that you guys already discuss this issue):

My Solution (recently found out): Use a very short USB-C cable (e.g. 30cm)! For me, now everything is working .. but that shouldn't be a permanent solution. p.s. Try it by yourself and report if that solves the issue also on your side! Would be a helpful information.

I please Apple for support and remedy. Lets support as community as much as we can. No finger pointing as everyone (Apple developer and tester) is doing their best. Report your experience unemotionally and share as many details / data as possible that are useful to recreate your case. I am very sure that with all the relevant information and recreating the case, Apple will work out a solution.

Thanks already in advance

  • Lets use the "Like"-Button to see faster if the short cable work around is working on your side as well.

  • my usb hub cable is like 10cm and it doesnt work unfortunately

  • Short update .. new cable ordered and delivered: Thunderbolt 3, USB4.0, length: 1,20cm

    Result: My connection with HP Monitor S340c is working as expected. PD working, Video-Connection working, Mouse and Keyboard working.

Me sucede lo mismo con un hub desde que actualicé a Monterey, antes con Big Sur funcionaba perfecto. Pero veo que es solo con los que tienen M1, puesto que en mi MacMini con Monterey Funciona perfecto, pero en mi MacBook Pro M1 con Monterey No funciona.

I have the similar issue, external SSD not detected after upgraded to official OS Monterey !!!!!!

Same problem, external ssd connects to thunderbolt port is not detected after OS Monterey upgrade!!!!!!

it was working fine prior that

Just bought an M1 Pro MacBook Pro 16 and my Sitecom USB-Multiport Pro Adapter + PD doesn't work correctly. USB 3.0 ports they all work fine, but not my ethernet port which I mostly rely on, as my workplace has a spotty wireless reception.

Please, please fix it ASAP! I tried to downgrade to Big Sur but, as expected, you can't do that to a new machine.

Same thing happened when Big Sur came out and we had to wait months in order to get our dongles to work. It's one thing we don't get the ethernet port on the adapter, like we do on the iMac, but not to have it on our external dongles is not acceptable for a machine costing 2900 euros.

Same problem as everyone, bought 34" Philips 346P1CRH/00 and everything worked fine on BigSur... After updating to Monterey, the video and ethernet works, but power supply is cut off. I'm on an M1 Macbook Air. :/

I have this issue.

If you too have this issue, can you please go here and report it:

Posting on the developer forums, may not be the best way to raise awareness to Apple about this issue. In order to try and get this issue resolved as quickly as possible, it needs flagging in the correct places.

Essentially, Monterey has broken support for a WIDE number of USB Hubs. Some USB Hubs work but certain ports on the hub do not, some Hubs do not work at all.

For me, USB-C & HDMI work on the hub, but my USB 3.0 port will only power devices and there appears to be no data transfer.

This issue is absolutely a Monterey bug. My devices were working fine prior to upgrading, and I have been able to replicate the issue and narrow it down by testing against a device that does not have Monterey installed.

Same issue here. Everything working perfectly fine with BigSur. Unfortunately I can't downgrade back since I don't have a back-up from that time (I know, was dumb) and since my MBA M1 won't detect usb, I can't create a bootable one.

Apparently this happened too with BigSur launch and took them 2-3 months to fix it so... Yeah.

I have a feeling Apple is just going to go with the "Sorry, your device is no longer supported so buy another one and pray it works" route.

Hope I'm wrong on both instances though.

Has anyone experienced this with a KVM switch? Just wondering.

can anyone check if the bug is present on the newest developer release?

Unfortunately facing same issue. Hope it will be fixed soon.

Same here. Belkin and ikling stopped working with USB mouse and keyboard. Little single slot USB -> USBc adapter works.

Same issue with M1 MacBook Pro and Grand-X SG-510 usb 3.0 hub :( USB ports aren't work, cardreader too, only hdmi still working

Same here on my Mac mini m1 and MacBook Air m1 with GC-HUB2 model AK61 and USBC-HUB model AK50.

USB 2.0 hubs are ok connected via USB->USB-C apple dongle

USB 3.1 Bus:

  Host Controller Driver: AppleT8103USBXHCI

USB 2.0 Hub:

  Product ID: 0x0101


  Version: 1.11

  Speed: Up to 480 Mb/s

  Location ID: 0x01100000 / 1

  Current Available (mA): 500

  Current Required (mA): 100

  Extra Operating Current (mA): 0

Keyboard Hub:

  Product ID: 0x1006

  Vendor ID: 0x05ac (Apple Inc.)

  Version: 96.15

  Serial Number: 000000000000

  Speed: Up to 480 Mb/s

  Manufacturer: Apple, Inc.

  Location ID: 0x01110000 / 2

  Current Available (mA): 500

  Current Required (mA): 300

  Extra Operating Current (mA): 0

USB Receiver:

  Product ID: 0xc52f

  Vendor ID: 0x046d  (Logitech Inc.)

  Version: 30.00

  Speed: Up to 12 Mb/s

  Manufacturer: Logitech

  Location ID: 0x01113000 / 3

  Current Available (mA): 500

  Current Required (mA): 98

  Extra Operating Current (mA): 0

Apple Keyboard:

  Product ID: 0x0250

  Vendor ID: 0x05ac (Apple Inc.)

  Version: 0.74

  Speed: Up to 1.5 Mb/s

  Manufacturer: Apple Inc.

  Location ID: 0x01112000 / 4

  Current Available (mA): 500

  Current Required (mA): 20

  Extra Operating Current (mA): 0

Me too, public release on M1 iMac, a previously fine usb device is stopped and 'too much power' message.