Volume Hash Mismatch


I've installed Monterey Beta 1 .... and then did an OTA update to MR B2.

After the update to MR B2 ... I've started to get this "Volume Hash Mismatch" in my notification center ...

I've tried to reboot into Recovery, and do a "First Aid" an all volumes in my MacBook Air's ssd ...

But this message still re-appears.

Any idea why this happens? or a fix?

cheers, Daniel.

  • Am experiencing this issue on a MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports). Applications crashing regularly. Did a clean install of MacOS Montery incl. re-formatting the disk about half year ago. Also NVRAM reset. Issue disappeared for a month or two but returned (though less crashes than initially till now). Currently running 12.2.1. My Windows machine at the office is more stable :-(

Add a Comment

Accepted Reply

[Update 2022-01-29]

macOS 12.2 seems to have a solution for this problem. I've done a complete clean re-install (with re-formating the entire drive).

I've run a 24hr Blackmagic Disk Speed Test, Safari open (the app that most usually made it trigger this issue). Without the issue.

Could more people try 12.2 too? and see if it solved their issue?

  • 12.3.1 still does not solve this problem. Very “un-Apple” issue. Reminds me of Windows. Anyone solved this on 12.3.1?

  • No , even on 12.4 beta2 the problem still exist.

  • I have an MBP 16 2019. I took it to the genius bar they are not able to fix it and sent it to a repair centre. They replace my logic board and Touch ID. So it is more likely the hardware problem.



I even did a total re-install of macOS Monterey Beta 2 (erased the SSD and a fresh install).

And yet again, this "Volume Hash Mismatch" is persistent


  • These ******* forgot to fix this issue even in production. My mac is a mess now.

  • Unfortunately I can't even downgrade. Because I bought my machine with Monterey install init.

Add a Comment

So, I did:

fsck_apfs /dev/rdisk1s5

From Recovery .... on all Volumes and the disk itself.

Back in macOS MR B2 ... Still getting this annoying notification hmm

  • I have same error now downgraded to BIG Sur.

  • Just notification or macOS will freeze and restart? Mine just keep doing this....

  • Just a notification in Notification Center that pops up.

Add a Comment

same... now just waiting for another quick update from apple.

  • Shutdown for one day, now is downloading Beta 3. MacOS is still running without restart.. weird

Add a Comment


I just started getting this today. The system is also unstable, I've been getting random Kernal Panics.

Update: I tried Beta 3 ... and now running Beta 4 .... on my MBA ... and I'm still getting them.

I have to say, it's gotten a bit worse ... since Finder and other vital "vital mac apps" crash and they won't re-spawn. And I end up with no apps running (read: showing). Funny when you just have the WindowServer app running and everything else has crashed, and didn't re-spawn.

Luckily pressing the PowerButton does pop up the "shutdown window" ... and I can restart my MBA from it (and not force...)

BTW: ... something I noticed is I was getting the error when using / having Safari open ... so I'm going to test using Firefox instead .... and try extra not to start any other "Apple apps" (just 3rd party apps) and see ...

  • Safari is one of my suspect apps as well. One of my crashes resulted from a Safari crash (report sent to apple). Other crashes (more often) are Windowserver crashes. And yes, it HAS gotten worse. Now I'm closing apps right and left to keep the system from stressing. Might be mem mgmt.

Add a Comment

I got the volume hash mismatch but it is not my volume where I downloaded macOS Monterey

Having this issue too, though without the popup and on Big Sur. I've discovered that a sudo purge works as a quick fix, though it ends up coming back. You can run it over SSH too if you can't open Terminal anymore. Hope there's a real solution for this soon.

Ok turns out my issue was caused by failing RAM, replacing it solved my issue (I have a MacBook Pro that has user-upgradable RAM). Probably not related to the issues in Monterey.

  • ... well, that was a looooooong time ago, we had those MacBook's wink-wink 😁

    But ... thinking about it .... if I have failing RAM memory ... why doesn't Big Sur or Catalina ... give the same error message? ... or that when I run the built in Diagnostic (hold "D" when you reboot, and you'll get into it ...) mode ... I doesn't warn / say anything about "Failing RAM" ...

    Glad swiping memory helped you 😊 ... but like a "logical vulkan (star trek) mind", it doesn't really compute

    PS. if you have an older mac, where "D" doesn't work ... try this: https://github.com/upekkha/AppleHardwareTest

Add a Comment

Is anyone still getting this issue with 12.1? I often get the notification and also experience a very unstable system with various app crashes. This did not go away with a completely fresh install (erase disk).

For what is worth I’m getting this issue on a 2019 16’’, another 2019 13’’ I own is running fine.

  • When I did a fresh re-install of macOS 12.1 (non-beta) ... I still got it the message on my MacBook Air 13".

    But it was like once / very very seldom ... that it pops up again. (I see an improvement, since the "Beta stage" ...)

  • Thanks, I’ll give 12.2 beta a go to see if it helps

  • I have to say that I can see some improvement with 12.2 beta. However after a day of use I did just get the dreaded notification again followed by couple of apps crashing. But for a day I have to say that the machine was way more stable than before, so some improvements have been made but it's not fully resolved the issue for me at least.

My MacBook (early 2015) has OS Monterey 12.01 with the same problem.

Add a Comment

I am facing this same issue with my 2021 16 inch MacBook Pro with M1 Pro chip. Earlier when I bought this laptop it was working just fine with Monterey 12.0 but when I updated to Monterey 12.1 I started seeing this "Volume Hash Mismatch" notification. Also, all of my regular use applications like Docker, PyCharm, VSCode, Slack, Chrome & Python are now crashing every 10 mins. I contacted apple support & was told to reinstall the MacOs Monterey using bootable USB. I did that & it didn't work. Then I was told to reinstall MacOs via internet recovery mode. I did that too but it didn't solve the problem. I was also asked to upload the screenshots of issues so that it can be escalated to their engineering team. Never ever heard back from the engineering team.

Then I was told to visit iVenus store(Apple authorised service provider) which is in Kothrud, Pune, Maharashtra, India. I submitted my laptop there and after a day I got it back with the freshly installed MacOS Monterey 12.1. The issue still persisted. I visited the iVenus store again the next day with those same issues. I was told to install application from App Store only as the third party application like Docker, Pycharm, Slack, Chrome, VSCode & Python are not yet supported by the Apple Silicon. I went to the website of these applications and pointed out the statement which says "Stable release for Apple Silicon".

I was denied to provide any further services by the iVenus store as their support team concluded that it is a problem of the application and it has to do nothing with the machine.

This morning I contacted Apple Support again and I was told to wait for another day so that they could escalate this issue to engineering team.

I will be receiving the next call tomorrow at 11:30 in the morning. I pretty sure "incapable apple" wouldn't be able to solve my issues.

I invested in a ****** product and yet the support team tends to congratulate me for using premium Apple product every time I got on a call with them.

Here are some of the screenshot I took recently -

  • I share your frustration. Had this issue with 12.0.1, 12.1 and 12.2 beta. My machine is with an intel chip so has nothing to do with the chip & apps.

    I gave up and went back to Big Sur which is working fine with no issues. I would suggest downgrading for now, this will be fixed in a future release I’d like to believe.

  • @akontaroudis unfortunately I cannot rollback as I bought this machine with Monterey installed in it.

  • @jeet9 ... IIRC ..macOS Big Sur is Optimized for M1. Though, you'd had to 1st back-up all of your files to an external disk ... and do a total re-install (including re-formatting the entire disk). But make sure you 1st have backed-up everything. There is no "going back" when you do a total re-install with re-formating the disk.

Add a Comment

Same problem in 12.2 beta2. It often appears when using safari , then Mac will freeze . I think Apple didn't notice this problem 😔

  • Mmm, I have noticed that too. Why I choose to use Firefox as the web browser in Monterey. As it didn't crash the system as often.

  • I can't tolerate this problem so I downgrade to Big Sur now my Mac works fine.🙂

  • Actually, in one of the worse crashes that I experienced with this problem) was when I had Chrome, Firefox and Safari open. I think Safari caused the problem, system crash, etc. but the one permanent damage was that Firefox lost my entire session (irretrievably). But it was more of an (traumatic) effect than a cause of the overall issue.

Add a Comment

Incompetent & Incapable Apple here are few more screenshots -

BTW Apple support has denied the repair, replacement or repair of my machine.

To the most asshole company of all time -

Here is another issue while reinstalling the MacOS Monterey.

  • I had this issue too ... it turned out that the SSD partition table got corrupted (happened when I played around why my test rigg). Try to re-format the entire disk and to a total clean install. BUT - 1st make sure to backup all of your files to an external drive.

  • Interesting, did you format the main partition or the MacOS Base System partition (recovery) as well? I've done a clean install already twice by formatting, removing and re-creating the main partition and problem always came back

  • @akontaroudis ... the entire disk. Helps if you 1st format it ExtFAT with MBR-partition table. And then do an AFPS with GUID-partition's ...

Add a Comment