Sudden crash on launch from all TestFlight builds

We've been getting a crash on launch starting today from all processed builds from TestFlight.

An identical build we submitted the day before yesterday is crashing on launch too.

Specifically the issue is:

Exception Type: EXC_CRASH (SIGABRT)
Exception Note:
Termination Reason: DYLD 1 Library missing
Library not loaded: @rpath/libswift_concurrency.dylib
"/usr/lib/libswift_Concurrency.dylib' (no such file)
(terminated at launch; ignore backtrace)
(no such file)

We're pretty concerned and after aggressive testing we don't think we're the root cause.

The same thing is happening to us today!!

The app runs fine under Xcode on an iPad connected by wire to my MacBook.

When we publish the app in TestFlight, it crashes immediately with the same missing library.

We were also getting an automated email after each distribution on TestFlight: ITMS-90863: Apple silicon Macs support issue - The app links with libraries that are not present on Mac:     @rpath/libswift_Concurrency.dylib

We were able to prevent these emails by navigating in AppStoreConnect to: App Store / Pricing and Availability / iPhone and iPad Apps on Apple Silicon Macs and un-checking "Make this app available"

We are seeing the same issue on our TestFlight builds since today. All the builds crash on startup with a crashlog (seen only by inspecting the logs on the device itself) indicating the same issue:

Termination Reason: DYLD 1 Library missing
Library not loaded: @rpath/libswift_Concurrency.dylib

My solution below works for me. Hope it helps

I managed to fix this with these:

  1. Installed the latest Swift package from apple:
  2. Installed the latest Swift Debugging symbols:
  3. Unchecked the "Make this app available" Apple Silicon Mac Availability in Pricing and Availability from AppStore
  4. Added the libswift_Concurrency.tbd in Link Binary with Libraries from Build Phases and set as optional

Seeing this too. Filed FB9801719 about it

The same issues for me!!!

Archiving & uploading with Xcode 13.2RC also resolves the issue.

It's working today, after I applied #4 from zack1001's post above - "Added the libswift_Concurrency.tbd in Link Binary with Libraries from Build Phases and set as optional."


An update. As per other suggestions updating to 13.2 RC resolved. This isn’t ideal.

I'm having the same issue.

App works fine when launched from Xcode, and even works fine when launched from Xcode as a release build. But when installed via Testflight, we get an immediate crash.

Here is the log:

Date/Time:           2021-12-08 13:29:31.3655 -0500
Launch Time:         2021-12-08 13:29:31.3603 -0500
OS Version:          iPhone OS 15.1 (19B74)
Release Type:        User
Baseband Version:    4.01.01
Report Version:      104

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note:  EXC_CORPSE_NOTIFY
Termination Details: (terminated at launch; ignore backtrace)
Triggered by Thread:  0

Thread 0 Crashed:
0   dyld                          	0x000000010519c198 __abort_with_payload + 8
1   dyld                          	0x00000001051a1d5c abort_with_payload_wrapper_internal + 104 (terminate_with_reason.c:102)
2   dyld                          	0x00000001051a1d90 abort_with_payload + 16 (terminate_with_reason.c:124)
3   dyld                          	0x00000001051722b4 dyld4::halt(char const*) + 328 (DyldProcessConfig.cpp:2046)
4   dyld                          	0x000000010516f578 dyld4::prepare(dyld4::APIs&, dyld3::MachOAnalyzer const*) + 3280 (dyldMain.cpp:0)
5   dyld                          	0x000000010516da04 start + 488 (dyldMain.cpp:869)

Thread 0 crashed with ARM Thread State (64-bit):
    x0: 0x0000000000000006   x1: 0x0000000000000001   x2: 0x000000016b872d80   x3: 0x0000000000000098
    x4: 0x000000016b872980   x5: 0x0000000000000000   x6: 0x0000000000000000   x7: 0x0000000000000000
    x8: 0x0000000000000020   x9: 0x0000000000000009  x10: 0x0000000000000001  x11: 0x000000000000000a
   x12: 0x0000000000000000  x13: 0x0000000000000036  x14: 0x00000002159ac609  x15: 0x0000000000000000
   x16: 0x0000000000000209  x17: 0x0000000105196830  x18: 0x0000000000000000  x19: 0x0000000000000000
   x20: 0x000000016b872980  x21: 0x0000000000000098  x22: 0x000000016b872d80  x23: 0x0000000000000001
   x24: 0x0000000000000006  x25: 0x000000016b873758  x26: 0x0000000000000001  x27: 0x0000000000000000
   x28: 0x0000000000000000   fp: 0x000000016b872950   lr: 0x00000001051a1d5c
    sp: 0x000000016b872910   pc: 0x000000010519c198        cpsr: 0x0
   esr: 0x56000080  Address size fault

Binary Images:
0x105154000 - 0x1051abfff dyld arm64e  <c21dba379df93fc7b286734030e18bb1> /usr/lib/dyld


There is no stack trace available in the crash.

I am downloading 13.2RC to see if this fixes it and will update.

Same issue. First encounter was 8 Dec 2021, 4am CET. Used most of the day yesterday to hunt it down, and found the problem was the missing libswift_Concurrency.dylib by looking in the device lock. So step 4 in @zack1001 solution above worked for me :-)

Same issue, although only versions < iOS 15.0 seem to be affected.

We're seeing the same thing. Migrating to Xcode 13.2 RC fixed TestFlight on iOS 15 devices, but iOS 14 devices are still crashing.

We also faced this problem in the same way. For us, it most likely affects only < iOS 15.

Fixed by disabling Bitcode.

We are waiting for a fix from our favorite fruit company ;)

Same issue here after making very few code changes. I'm trying to understand, does the "Processing" they do for the App Store remove certain libraries?

same issue downloading Xcode 13.2 RC to see if it fixes it :(

In our case, our app (deployment target of iOS 11) was hit with this issue when uploading a Bitcode enabled (or disabled) build that was compiled with Xcode 13.2 RC Since we support iOS 11, we don't even use Swift Concurrency features so the issue came as a surprise to me. I tracked the problem back to the fact that one of our dependencies (RealmSwift) has some async code which while it wasn't used, it was enough for Apple to break our build when they processed it :D We recompiled Realm of verion 10.14 and everything is ok

Same issue. @zack1001 solution above worked for me at with Xcode 13.1.

Also seeing this with tvOS

Here's a thread on the Swift forums about this issue FYI:

Thank you for reporting this issue. We are currently working to resolve this. In the meantime, a workaround can be found in the Xcode 13.2 Release Notes. (Bug number 86349088)

From the release notes:

Apple Clang Compiler

Known Issues

Apps built with Xcode 13 or Xcode 13.1 that make use of Swift Concurrency features (such as async/await), deploy to iOS prior to 15, tvOS prior to 15, or watchOS prior to 8, and have bitcode enabled may crash at launch with an error reporting that the libswift_Concurrency.dylib library was not loaded. (86349088)

Workaround: Add -Wl,-weak-lswift_Concurrency -Wl,-rpath,/usr/lib/swift to Other Linker Flags in the app’s build settings.

In iOS 12 have same issue.

We add  -Wl,-weak-lswift_Concurrency -Wl,-rpath,/usr/lib/swift to Other Linker Flags in the app’s build settings and build using Xcode 13.2 (from developer site) but app crash on iOS 12.

If you have a same problem, please TURN OFF Include bitcode for iOS content option when you upload build. then works normally.

Don't think turn off bitcode is a great solution, we will lose benefits (e.g. app thinning)

Adding libswift_Concurrency.tbd did not work for me on Xcode 13.2 (not even RC). I was forced to go back to 13.1, which worked, and hope Apple can get it resolved soon.

Sudden crash on launch from all TestFlight builds