No Developer Mode option on iOS 16 device.

Hi, I'm really hoping someone can help me. After updating my iPhone 11 to iOS 16 and tried to launch an app from xCode on it, I noticed that I didn't have dev mode enabled. When I went to Settings > Privacy & Security to toggle the Developer Mode on, it wasn't there. There is no Developer Mode option in my settings, the only option and the end of Privacy & Security is Lockdown Mode.

I tried so many troubleshooting techniques and spent a lot of time looking for solutions. I tried powering on and off while connected to my macbook with xcode running and again without xcode running. Made sure my device has the latest update (iOS 16.0.2) and my device has trusted the connection to the Macbook as well. I also had the same problem on my girlfriends brand new iPhone 13, I was really hoping it was just my device but no, her device doesn't have the Dev Mode option either. Out of curiosity I asked my friends at work if they had the option but they did not. I even went as far as going into an Apple store and checking the devices on display and they didn't have the option either. And when I asked the staff their, they didn't know why the option wasn't showing up on mine or even their own personal devices.

The only source that I have found with the same issue as me is this youtube link (, where it mentions that this is an issue with iOS 16 public beta users and not developer beta user and the only way to solve this is by sidloading the app which I am not gonna do. Please note that I am not running beta version on my device.

I can't help think that there's something obvious that I'm missing or need to do but just can't find it.

Any help or advice will by really appreciated :)

Thank you

Answered by Claude31 in 730839022

Usually it is enough to:

  • Having launched Xcode
  • connect iPhone to the Mac via USB
  • Switch mode on device

But, to make a long story short, better contact support.

Accepted Answer

Usually it is enough to:

  • Having launched Xcode
  • connect iPhone to the Mac via USB
  • Switch mode on device

But, to make a long story short, better contact support.

Thanks for the feedback Claude31, yeah it really does seem that I might have a bug or something wrong. I updated my Macbook and xCode during the night but had no luck.

I'll take your advice and contact support. And when I have the issue solved, I will share the steps here. Surely I can't be the only one with this issue, but one way or the other I will solve it ha.

Thanks again :)

Hey, my developer mode option has just appeared today. I didn't do anything different since my last post as Apple Support had no idea why I couldn't see the option and they said they will get back to me but I heard nothing back yet. It was strange and frustrating to see the option just appear like that after so much time and effort to solve this issue ha. All I did was the steps Claude31 has mentioned above (which I have done many of times) and it just worked today. Anyway just wanted to let you know that I now have developer mode option up and running on my device. I have heard there are a lot of bugs with the iOS 16 so I guess we can just add this to the list of rare bugs.

Thanks :)

I have the same problem on iPhone 12 (iOS 16.0.3), has anyone found any solution to this problem?


I am facing the same issue with iPhone 13. (iOS 160.3)

Hi same problem :-( iPhone 13 Pro an iOS 16.0.3 it's urgent ... do you know of any fix?

Hi! My iPhone 13 Pro didn't have developer mode either. It helped me that I turned off the VPN. I think there is a conflict with the security of the device.

I found a logical (though not easy) solution: you have to add your device to your Apple Developer account. Under "Certificates, Identifiers & Profiles" go to "Devices." Then click the + icon.

The tricky part here is finding the device's UUID. After physically plugging in your phone to your Mac, click on the name of the phone in Finder, and the info will cycle through until UUID shows up. You can't copy and paste that info (thanks, Apple!), so you have to accurately type all the characters in.

here is the doc from apple on ios16 however. as others have noted on the forum, you may need to restart the device before the option is there. this was the case for me.

After updating the os I had to manually shutdown and restart the iphone. After which dev mode was there again

Hello , am facing the same problem , can’t find developer mode , using an iPhone 14 pro max , 16.2 , I don’t really what do , or is there a new way to enable ?

I was experiencing this as well. I had just updated my iPhone 11 Pro Max to 16.2, my Macbook to Ventura 13.1, and Xcode was freshly updated. I got Developer Mode to appear by:

turning off my phone for 10srestarting my macbookopening xcodeconnecting my phone to my macbook

Hope this helps someone. ✌🏽

Hello, I am not sure that it will work. But in my case, first I updated my Xcode

and power off my iPad to restart it And I disconnected and reconnected USB C cable a few times and then closed setting app and turnoff … finally it showed in the end.

When you first go to privacy and settings you will not see the developer mode. To enable developer mode, first you need to go to Xcode -> product -> destination -> choose your device Follow the prompts, now when you go back you can see the developer mode and toggle it on.

Connect to your MacBook and launch Xcode

I was able to fix this issue after enabling developer mode in iPhone settings and restarting the phone. THEN I connected it to my MacBook with both Apple Configurator, and Xcode opened. Pretty sure opening Xcode helped, as Dev Mode just appeared in settings without having to relaunch the settings.

I had two devices with no visible Developer Mode option.

I sucessfully updated both of them, with following steps

  • connected devices to mac.
  • goto settings main screen on iPhone/iPad.
  • select target as device, hit Build/Run on them via Xcode.
  • you'll see standard cannot run message on Xcode.
  • visiting Privacy & security now results in Developer Mode option available.

Hope this helps.

Oddly disabling any active Focus mode (like Sleep, Personal, etc...) made the option appear for me in Settings > Privacy & Security > Developer Mode.

I had no VPN and my phone was plugged in with xCode opened. Hope this helps ^^

I just solved this problem by installing an app that requires development mode. So it wasn't show up because there is no app that requires development mode.

Turning on Wi-Fi did the trick for me

Following worked for me

  1. Connect iPhone/Device to mac.
  2. Open XCode > Window > Devices and Simulators.
  3. Under devices select the "+" icon in the bottom left.
  4. Select your device and click Next/Done.
  5. On the iPhone make sure you don't have settings open (i.e. force close it.).
  6. Open settings > Privacy and Security
  7. Scroll to the bottom and Developer mode should now be there.

My problem was with step 5, I already had settings open and for what ever reason developer mode wasn't showing so had to exit and reopen settings.


I have an iPhone 13 Mini. When I attempted to run an app I was developing on my phone, I found that the Settings > Privacy & Security > Developer Mode was missing. I realized that I was still associated with a defunct app developer team from several years ago. So I left the team (, updated my developer account, and then rebooted several times but Developer Mode was still not showing up. I began to think that joining the fee-based Apple Developer Program might be required.

I checked back yesterday (after ~4 days had elapsed) and noticed that the Developer Mode option was available (even though I had NOT joined the fee-based Apple Developer Program). So for anyone reading this, allow for system latency after leaving a team and/or updating your account.

Thanks, it sucks I don’t own any kind of computer but at least I know why they removed it like that.

but.. how do you do that if there is no mac and no xcode... I am trying to distribute a test app to registered devices, but they cannot get into developer mode

they live on the other side of the country and are just users of the app, not developers..

I find a warning for my apple id says I need to login again, or something may not work correctly. Then after I login my apple id again, the developer mode switch shows up.

What worked for me :

Open Xcode "14.3.1" then :

  1. Go to Product -> Destination -> Manage Run Destinations
  2. Click on your device and press unpair
  3. Click on + and add your device
  4. Finally press enable developer mode on device (from Manage Run Destinations)

Now on Your device :

Go to Privacy & Security :

  1. In the bottom the option now shows up
  2. Enable you will be prompted to restart

Here you go !

As someone else mentioned, the option appears once the device is connected, has been trusted, and you have opened XCode.

No Developer Mode option on iOS 16 device.