Profile doesn't include the com.apple.application-identifier entitlement.

I have tried everything and still I am getting this. Just for a test I created a new app (Master-Detail template Xcode 11.5) I have created an entry in the iTunes Connect to receive the app upon archiving and uploading. I regenerated all new certificates for iOS Development and Distribution. I created all new Provisioning profiles.

The Dev profile builds deploys and runs on my device
The Dist profile builds but when I select the distribution profile I get the "Profile doesn't include the com.apple.application-identifier entitlement." error.


When I download the profile within Xcode all looks good for the distribution profile:
App ID: matches correctly
Certificated: 1 Included includes the new signing certificate "iPhone Distribution...."
Capabilities: 3 Included Includes Game Center, In-App Purchase, and Keychain Sharing
Entitlements: 5 Included Includes application-identifier, keychain-access-groups, beta-reports-active, get-task-allow, and com.apple.developer.team-identifier.

Im not sure what is going on. This is a standard process I have performed for quite a while. As a matter of fact I just submitted 3 applications last Sunday.

Thank you for any suggestions.
Post not yet marked as solved Up vote post of gbacklin Down vote post of gbacklin
5.5k views

Answers

Ok, I just created this same app on an older Mac mini running Mojave and Xcode 11.3.1. I exported my profile from the Xcode 11.5 and imported it to Xcode 11.3.1 and everything worked as expected and was able to upload it to iTunesConnect.

A thing to note this is running Xcode 11.5 on the Big Sur beta. Also the same error appeared with Xcode 11.6 beta but not with Xcode 12.


Me too
I got a new way to fix that:

Building with Xcode 11.5,
Then distribute it with Xcode 12 beta.

😂
Same here
Abnex's answer could have saved me over 24 hours of uninstalling/reinstalling/testing. After I built my archive in Xcode 11.5, I uploaded with Xcode beta 12 and it was accepted.

Super annoying glitch, but I guess that's on me for using beta.
@tranced

I had waste 8 hours on certificates/Profiles/fastlane/github actions... 😂

Finally, I found that the simple way is the best way...😂
so this Is a 11.0 specific problem....
Same here
Also I've opened up an issue here
https://github.com/fastlane/fastlane/issues/16681
OMG this problem cost me two days now, no reply from apple but your suggestion fixed it.

Build with 11.5, Archive with 12 beta. Thanks
Had the same problem here running Xcode 11.5 with macOS Big Sur. Distributing with Xcode 12 as suggested in comments solved the issue.
I am going through the same issues here too guys.
Ughhhh, exact same problem here, thx for sharing
Thanks for sharing! it works with Xcode 12
Thanks for sharing! it works with Xcode 12 (2)
Issue fixed in macOS Big Sur 11 Beta 2 Thanks Apple 😀