MacOS Big Sur Lagging

Hello! Help please, after updating the system to Big Sur, my MacBook Pro 13 began to slow down, previously there were no such problems.

MacBook Pro (Retina, 13-inch, Early 2015)
2,7 GHz 2‑core processor Intel Core i5
8 GB 1867 MHz DDR3
Intel Iris Graphics 6100 1536 MB
Post not yet marked as solved Up vote post of Seplaz Down vote post of Seplaz
80k views
  • I'm glad it's not just me. Was beginning to think there was something wrong with my Mac. I bought the i9 iMac and really spec'd it out; built to order. But on Big Sur I get stutter animations. If I slowly move my mouse around the cursor is jittery. Almost like it's a bluetooth error but I know it's not. Watching videos and some of them will stutter too. Scrolling stutters. I have to shutdown my computer and restart to clear it up.

    And my Apple Wireless Keyboard is not wireless anymore. I have it plugged directly in with a lightning cable because trying to type on it wirelessly would lag and mess up.

    This is pretty ridiculous. I hope macOS 12 fixes this.

  • It works! mcbkpro 13 late 13 2.4 i5 8G ram BigSur(unfortunately)

  • iMac (Retina 5K, 27-inch, Late 2015) 3.2 GHz Quad-Core Intel Core i5 32 GB 1867 MHz DDR3 AMD Radeon R9 M390 2 GB

    The 11.5.1 update caused video/trackpad stuttering. I also lost my directly-connected Dell monitor (iMac thunderbolt to Dell DisplayPort) video. Turning off the Dell fixed the stuttering. Moving the thunderbolt connection from the iMac to my CalDigit hub fixed the second monitor issue. Is it possible to update or reset the iMac's thunderbolt port? I've reset the PRAM so far...

    ` Vendor Name: Apple Inc.

      Device Name: iMac

      UID: 0x0001001901E3F1E0

      Route String: 0

      Firmware Version: 28.1

      Domain UUID: 3D365C05-5471-5A50-BA61-960AEA98039C

      Port:

      Status: Device connected

      Link Status: 0x2

      Speed: Up to 20 Gb/s x1

      Current Link Width: 0x2

      Receptacle: 1

      Cable Firmware Version: 0.1.22

      Link Controller Firmware Version: 0.16.0 `

Add a Comment

Answers

It's the same for me... Same spec and Big Sur lagging like crazy! I'm very disappointed...
Same configuration, same problems.

Lags a lot. Have reset SMC, but it didn't help.

Please do something with it.
MacBook Pro 16 core i9 lagging and freezing , I can’t work after update and don’t have time to downgrade. ***? Beta worked more stable without that issue
MBP16 i9 and mad laggy
MacBook Pro (15-inch, 2019)

Same here. Scrolling, typing, selecting menu items, clicking buttons, selecting finder windows - lags like crazy. Often the wheel is spinning for several minutes, sometimes the system appears simply to be frozen.

Ran CleanMyMac, reset SMC, PR Ram. Turned off animations and transparency. The latter seemed to have helped a bit, but still - it is unacceptable.

Even as I type this, the wheel appears, input puffers and mouse movements, clicks and keystrokes seem to be buffered, the fired all at once.

Catalina worked perfectly fine with all graphical enhancements turned on.
Same here. Please do something with it. It is impossible to use it....
Same issues here on my 13" 2020 Macbook Pro i5. Stutter animation, hangs and delays even with Apple's stock applications.
Hope Apple will fix it in the next update. Big Sur is such a let down.
Macbook Pro 2017 13". Updated to Big Sur. Nothing but LAG. Gaming Lags. Normal Desktop use Lags. Hangs, freezing, dock icon is absolutely jittery. Never seen it this bad before.
Same thing. MBP 13" 2020 10th gen. Even magnification in dock is stuttering.
Same here. Macbook Pro 2018 i9, so many lagging and crashes. Bug Sur.
Playing games in Steam, e.g. Borderlands 2, on my

Pro (13-inch, 2018,
2,3 GHz Quad-Core Intel Core i5
6 GB 2133 MHz LPDDR3
Intel Iris Plus Graphics 655 1536 MB
running Mac OS 11.0.1 Big Sur

is really laggy even after i turned down resolution and all other graphic enhancements to low or off.
Before upgrading everything was fine on MAX settings.
Cheers
Same for me on an MBP 16" 2019 model.

Its laggy even to type in Pages. Mac OS Big Sur 11.0.1.

It seems to be related to the GPU, because turning off the automatic graphics card switching seems to improve the situation at least temporary and superficial.

It remains unclear, if it is related to a problem with Intel GPU or GPU in general and the reason it doesn't appear on the AMD GPU (5500 M, 4GB) may just be related to its increased computing power.

Hopes are up for a quick fix, I don't like the idea of going back to Catalina, but as it is right now, it destroys all the fluidity in the workflows I love so much while using my Mac.

Best regards
  • UPDATE and found my personal solution after half a year...

    Now, on Big Sur 11.4, in July 2021, I was still annoyed by some level of choppiness of the UI, especially while running on the Intel GPU. For example, I had noticeable lags while typing in Pages, as if this great Laptop was seriously to slow to process simple word processing. Don't get me wrong, everything usable in a decent way, but with micro stutters and little hiccups on a regular basis. On top of that, battery drained 50% in 2,5 hours working in Pages with some background Apple Music running, nothing fancy - to much for my nerves, knowing I spend 3,5 grand for this machine not even a year ago ...

    So I looked into it, and found out that the screen saver was taking some amount of CPU-time. Not much, like 3-5 % of total CPU. This, of course, without it being active, because I was using the system. I had this switched on all the time because I use remote access from an iPad often, and sometimes the system would have long idle times.

    So, I decided to switch the screen saver off to test this out and guess what - my MacBook Pro 16 inch went instantly back to snappy UI handling. No issues anymore with Safari browsing, typing in Pages and so on. Felt like o.g. Catalina for me, especially on Intel GPU. Finally.

    Long story short, give it a try - switch screen saver off. Worked for me.

  • Wow! @Sherman13's solution worked for me, too. I have an older MacBook Pro Retina 15" mid-2014. Turning off the screen saver seems to work wonders. Thanks for the suggestion, and hope this helps someone else, too.

  • Never would have guessed this but it worked! Thank you so much, I can keep using my MacBook Air (Early 2014). Wondering what went wrong during development that such a weird bug is present in the system

Add a Comment
same here with MBP 2017
Same over here, MCP 2016 i7 2,6ghz.
The only way to improve is to deactivate automatic graphics switching in the battery settings and always use the secondary more powerful graphics card (I have the 2gb radeon 450).
Let's hope for a quick fix as it drains my battery pretty quickly
Same here, after that Gatekeeper incident, things have been very poor in general. Beach balling during the simplest tasks. Catalina seems very nice right now.

Macbook Pro 15" Late 2016
Quad-Core Intel Core i7
16 GB 2133 MHz LPDDR3
Radeon Pro 460 4 GB
Intel HD Graphics 530 1536 MB