Xcode unsupported iOS version after beta update 14.5 error 18e5140k

Hello everyone,
after I've updated my iPhone to iOS beta version 14.5 , Xcode cannot run my app.
My Xcode is updated to the last versione because the Xcode beta versione isn't suitable for my MacBook Air 2012 with Catalina.
Can you help me?
  • Hello all, I need to create various environments for each ios version between ios version 12 and ios version 15. Please tell me how, I need a solution. Thanks

Add a Comment


18e5140k is just the iOS build number.

What is the complete message you get.

Did you try reboot both iPhone and Mac ?

Note: in the documentation for beta, it is stated that you do it at your own risks… It is not a very good idea to do thins on a device you need, you should do it on a scapegoat iPhone…
Thank you for the answer.
There is no error, the only problem is that Xcode not recognize my device that use the new beta version iOS 14.5
I know the solution (install new Xcode beta version on Big Sur), but I cannot install Xcode beta because I've got a MacBook Air 2012 not compatible with Big Sur.
My phone works properly, I installed the beta version because I need to test my app on it.
Do you know if there is other solution?
18e5140k is a new version of 14.5 beta2, released feb 4th.

Did you check you have it installed (18e5140k).

The previous one (18e5140j) had a lot of issues with APP.

https ://www.reddit. com/r/eero/comments/ldlb3t/ios145beta218e5140k/

Or from https ://www.igen. fr/ios/2021/02/beta-1-dios-145-apple-livre-une-nouvelle-build-120453

This build provides a fix for Office applications that could not be launched since the first beta. The bug affects software that uses APP (App Protection Policy), Microsoft's office suite, but also other applications.

hello everyone,
i solved the problem by adding iOS 14.5 the device support file inside the Xcode app in path contents/Developer/platform/iPhoneOS.platform/DeviceSupport
You can download it from GitHub or you can download the new beta version and grab the directory from it.
  • Thanks, It works

  • Thanks, it works!

  • thanks man. really good help!

This did the trick. Thanks!

Thanks @MicheleC, it works!
Thank you very much @MicheleC
It's work with me

Unfortunately, it didn't worked for me.
I added the iOS 14.5 device support file into the Xcode app, but after the build and run, I got the following message: "Failed to prepare device for development". (iOS 14.5 release, Xcode 12.4 (12D4e)) And the weird thing is, in Xcode the maximum iOS deployment target can be only up to 14.4
MicheleC's instructions were simple, I think I followed it right. So, I don't understand what is the problem.

Can I ask your opinion, please?
Thank you @MicheleC, @TKincses try Clean build folder and remove your app from iPhone! Making this solved for me the problem with "Failed to prepare device for development".

I also received the "Failed to prepare device for development" error. As @CelsoRZ said, @TKincses try Clean build folder and remove DerivedData folder located in /Users/user/Library/Developer/Xcode/DerivedData, after that I reset Xcode and it worked for me.
I upvoted the answer by @MicheleC, and it worked, BUT...
... whenever I run the app in debug mode on my device, and I put a breakpoint, the debugger crashes.
But still a progress, at least I can install the app on my device. I'll debug on the simulator.

Xcode doesn’t support iOS 14.6 (18F72).

  • I have the same issue with 14.6, running XCode 12.5

  • Same here. Apple should have Xcode support the latest iOS whenever it is released.

  • I just reupdated to XCode 12.5 and the error went away. XCode did not add iOS 14.6 in its dropdown list of supported versions. But I was able to run a build into my phone and debug.

any sulotions?

Xcode doesn’t support iOS 14.6 (18F72).

I have such a problem too

This might be a temporary solution but here is what worked for me:

  1. Go into contents/Developer/platform/iPhoneOS.platform/DeviceSupport
  2. Copy your previous iOS 14.5 the device support file or older version
  3. Paste into the same folder and change the iOS number to 14.6
  4. Restart Xcode, and it should let you run your code on your phone

FYI this has worked for me before too for a different iOS so it might be able to help for later versions if anyone gets stuck or cant run Xcode on their phone. Hope this helps!

  • do not work with Xcode 12.3 on Catalina

  • This trick is not working with Xcode 12.4

  • It works. Thanks. Xcode 12.4 and ios14.6