xcode14:Library not loaded: /usr/lib/swift/libswiftCoreGraphics.dylib

  • Facing the same issue. Will leave a reply with the details we have noticed so far.

  • I have the same problem with app submitted to TestFlight and running on iOS10.3.4. using xCode 13.4.1 to build App run fine started from xCode (debug or release mode) on the device App run fine on device under iOS 15.7 even with TestFlight Problem is there since at least 01/09/2022

    Feedback : FB11529856

  • Can I please ask the question author to not mark it as accepted/resolved so that it does not affect the visibility of the issue?

Apple Recommended

  • Glad to hear that!

    I have a follow-up question. If we still use Xcode 13.4.1 and enable bitcode, then we upload it to the App Store later when Xcode 14.1 is released, would the benefit of bitcode still remain on that build? In our previous app releases, turning on bitcode would reduce the App Launch time by a couple of hundred milliseconds.


  • Hi, if I've updated to Xcode 14.1 RC, should I enable bitcode or not?

  • Disabled bitcode in Xcode 13.4.1 solved my problem, but I wonder that when I update to Xcode 14.1 in future, could I enable bitcode? and what's bitcode is deprecated in Xcode 14 mean, is that the same whether you set it enabled or disabled? Thank you.


Same issue here. Xcode 14.0 + iOS12.0. Termination Description: DYLD, Library not loaded: /usr/lib/swift/libswiftCoreGraphics.dylib

No problems with Xcode 13.4.1 + iOS12.0

  • libswiftCoreGraphics.tbd add to Link Binary With Librarires can resolve this problem

Add a Comment

If you run your app from the Home screen on the 10.3.3 device, does it crash? If so, please grab the resulting crash report and post it here.

For advice on how to post your crash report, see Posting a Crash Report.

Share and Enjoy

Quinn “The Eskimo!” @ Developer Technical Support @ Apple
let myEmail = "eskimo" + "1" + "@" + "apple.com"

We're observing the same issue on Xcode 14 iOS 12.1.4. No crash if deployed from Xcode 13

We've been facing the same issue since the first Xcode Betas until the public release that we recently released.

I have tried creating a sample app with Xcode 14 and it does not happen with that, hence my suspicion is that there is something specific with our project that is causing the package produced by Xcode 14 to have this issue. The same project with Xcode 13 does not demonstrate this issue and the packages generated using that work fine on iOS versions below 12.2.

Error seen in Xcode console:

I have compared the binaries created by both Xcode 13.4 and 14 and following were my observations.

Command run: `otool -LD

With Xcode 13.3.1 (13E500a) when we search for the phrase libswiftCoreGraphics we notice only one occurrence.

With Xcode 14 when we search for the phrase libswiftCoreGraphics we notice two occurrences. With the /usr/lib/swift/ one being the same occurrence that Xcode shows in console.

Crash log from device:

DTS ticket ID: 101794668438

Feedback assistant: FB10905587

TSI ticket: 808801996

Sounds like the same issue as mentioned here.

I filed a feedback, FB11512459, but have not heard anything as of yet.


I am using Xcode 13.4.1 and the submitted app store version keeps crashing in iOS 9.3.5 and iOS 10+. but Adhoc builds working fine only App Store build getting crashing.

Dyld Error Message: Dyld Message: Library not loaded: /usr/lib/swift/libswiftCoreGraphics.dylib Referenced from: /var/containers/Bundle/Application/85C5C95A-90F7-4B4C-B84A-93B92BD967CB/Magzter6.app/Magzter6 Reason: image not found Dyld Version: 390.7

Apple Feedback complaint No. : FB11515032 reported on Sep 15, 2022 at 11:08 AM

  • Use xCode 13.4 (download it from support download) and then be sure that swift libraries are embedded (build setting) and upload without the 2 first options (BitCode off, strip swift symbols off) : then you can run from TestFlight on iOS 10 and from AppStore once accepted.

  • How to use TestFlight for lower ios 10 devices . TestFlight supports from iOS13 only .

Add a Comment

This is the crash log for my 10.3.3 device

TSI ticket: 808801996

That’s been routed to one of my colleagues, so I’m going to defer to them in this matter.

vijaytholpadi, once you get an answer via that TSI, I’d appreciate you posting a summary here.

Share and Enjoy

Quinn “The Eskimo!” @ Developer Technical Support @ Apple
let myEmail = "eskimo" + "1" + "@" + "apple.com"

  • Is this the same issue as mentioned here? I am asking because this one is for libswiftCoreGraphics.dylib while that one is for libswiftCoreData.dylib.

Add a Comment

Is this the same issue as mentioned here?

Almost certainly.

Since yesterday I’ve learnt more about this issue, although I still don’t have a full answer for you. All I can say right now is that, as far as we can tell, this is an issue on the Apple side of things (r. 100194032).

Share and Enjoy

Quinn “The Eskimo!” @ Developer Technical Support @ Apple
let myEmail = "eskimo" + "1" + "@" + "apple.com"

Crash from one of our users with: "Library not loaded: /usr/lib/swift/libswiftCoreData.dylib" Binary was built with Xcode 13.4.1. And we don't use CoreData at all.

It looks like an AppStore rebuilds app with bitcode using Xcode 14 toolchain. 🧐

Followed @Ptit-Xav's recommends and. its worked for me. App working iOS 9 . check its comments

Seems that xCode 13.4.1 can not distribute for pre iOS11( this can be checked in TestFlight). Even if debug is still possible. The only workaround I found was using xCode 13.4 and doing some extra configuration :

Build Settings / deployment / oAlways Embed Swift Libraries = Yes Build Settings / deployment / strip swift symbol = No Also when uploading : unselect 2 first options about BitCode and Strip Swift Symbols Tested successfully with iPhone 5 iOS 10.3.4 In the release notes of xCode it is not always easy to determine the lowest supported iOS version. New xCode 14 suppressed iOS10 and below support : it means all non 64 bits processor devices not supported. Debug is no more possible.

-- Comments from @Ptit-Xav

I meet the problem too. I use xcode 14 and run to iphone 11.2 , and my app crashes when runs. The crash log is " dyld: Library not loaded: /usr/lib/swift/libswiftCoreGraphics.dylib Referenced from: /var/containers/Bundle/Application/aaaaa/bbbb.app/bbbb Reason: image not found" And I resloved it by set weak link to "buildsettings- Other Linker Flags", like this:-Wl,-weak-lswiftCoreGraphics -Wl,-rpath,/usr/lib/swift

We've been looking into this issue, and it took some time to understand the different scenarios presented by the crashes you are reporting involving CoreGraphics, Foundation, and CoreData. Thank you to those who filed bug reports in Feedback Assistant, provided full crash reports here on the forums, and filed Technical Support Incidents.

There is a single underlying issue which affects the Swift runtime support for OS versions prior to the addition of the Swift runtime as a library provided by the operating system This issue is then manifested as a crash through 2 different paths.

  1. If you are building your app with any version of Xcode 13 and submit these builds to the App Store, your app downloaded from the App Store will crash with a missing library error when run on iOS 9 - 12.1. You can avoid this crash by disabling bitcode in your app's build settings, rebuilding your app, and submitting an update to the App Store. In general, you are able to build and test your app on these iOS versions directly from Xcode without being affected.

  2. If you are building your app with Xcode 14 or Xcode 14.0.1, your app will crash on older OS versions, including while building and testing directly from Xcode, as well as after submitting the app to the App Store. The OS versions affected include iOS 11 - 12.1, macOS 10.13 - 10.14.3, as well as watchOS and tvOS versions from the same time frame. To work around the crash when building with Xcode 14, add -Wl,-weak-lswiftCoreGraphics (substituting other library names for swiftCoreGraphics if appropriate for your crash) to the Other Linker Flags build setting.

To verify the workaround for the second scenario, inspect the binary with otool -L /Path/To/Binary before and after applying this setting. Before applying this setting, you will see the Swift library referenced at /usr/lib/swift/libswiftCoreGraphics.dylib (again, substituting the appropriate library name given your crash report), and after applying this workaround, you should see that change to @rpath/libswiftCoreGraphics.dylib instead, which is what you want to see.

  • Will this issue be fixed in future Xcode versions? Or is it up to the developer to change the local configuration?

  • It not working

  •  px1013, this is meant to be a workaround to alleviate crashes. We don’t expect this workaround to be a permanent solution.

My situation is the same as yours. Xcode 13.4.1 runs and packages normally under iOS11 - iOS2.2, and crashed directly under Xcode 14. My solution is to make the following settings in each target (including Pods target) using Swift under Xcode14: General ->Frameworks and Libraries Add a reference to libswiftCoreGraphics.tbd, and it will be normal after re running and packaging