Can't upload to AppStore - Invalid Provisioning Signature

After updating the Xcode to 13.3.1, and after some time since my last release, I can't seem to upload my app to AppStore.

And I get the following error:

Invalid Provisioning Profile Signature. The provisioning profile included in the bundle 'MY BUNDLE HERE' (Payload/ cannot be used to submit apps to the iOS App Store until it has a valid signature from Apple. For more information, visit the iOS Developer Portal. With error code STATE_ERROR.VALIDATION_ERROR.90165

I'm not sure what I broke with the latest update, since it worked fine until now. I tried messing with Archive Scheme in Xcode, I tried adding new provisioning profiles (AppStore and AdHoc) on the site, but it doesn't help.

My gut's telling me that the solution is obvious, but...

  • same here [Xcode Version 13.3.1 (13E500a)]

  • I'm also having the same issue today

  • Why it is happening, don't you know?


same here, how did you fix it?

  • You go to, choose your provision, then click edit (no need change anything), save and download it. Install this provision. It works for me.

  • Here don't work

  • I had same issue, with Xcode Version 13.3.1 (13E500a), I just deleted the existing provision profile and certificate from the KeyChain, Go on Developer.Apple.Com, Selected the existing provision profile that I was using and click edit and just save did not make any changes and then download it on my machine. Then install both certificates and provision profile and it solve my problem.

Add a Comment

You are not alone. This suddenly started happening foe us too.

same here XCode Version 13.2

ok so I'm going to bed, i wait that Apple will fix it.

Same issue on my side

ITMS-90165: Invalid Provisioning Profile Signature - The provisioning profile included in the bundle '***' cannot be used to submit apps to the iOS App Store until it has a valid signature from Apple. For more information, visit the iOS Developer Portal.

Same here! No hope. Xcode Version 13.3.1 (13E500a) #ITM-90165 / ITM-90165

Same here with Xcode 13.3.1

Lucky for me, I have another Mac with Xcode 13.3, which didn't yet update. Archiving from that Mac worked without any issue.

  • I'm still on Xcode 13.3. I can't still upload the build. :|

Add a Comment

I'm on Xcode 13.3 too, but same issue..

  • Same here: 13.3 (13E113)

Add a Comment

Same here! Using Xcode 13.2

Post not yet marked as solved Up vote reply of u98x Down vote reply of u98x

I have the same problem XCode 13.2 Yesterday I uploaded but today I can't :/



happening for me as well

Happening here too. Very frustrating!

I had the same issue. Creating a new Distribution certificate through Xcode allowed me to upload.

  • That's right!!! I't solves to me here!

    Creating a new Distribution CertCreating a new Apple Dev Cert (not sure if necessary)Clean Product Build folderArquive -> Validate -> UploadSuccess!!

    Thanks man!

  • I have same issue. Uploading was possible yesterday, but not today. As you said, I created a new Apple Distribution Cert and succeeded to upload. It took hours. Thanks for @valuedcustomer and @MarcioSantos!

  • I had the same here. It's salves when I created a new Distribution Cert as well!! Thanks a lot!